quartz to X11 paste

2001-05-08
2001-08-10
  • Jeff Whitaker

    Jeff Whitaker - 2001-05-08

    Right now the contents of the quartz pasteboard are copied to X_CUT_BUFFER0.  This means that xcutsel has to be invoked to copy CUT_BUFFER0 to PRIMARY before a middle mouse click will dump the contents in an xterm.  Should the quartz pasteboard also be copied to X_PRIMARY to eliminate this step?

     
    • Greg Parker

      Greg Parker - 2001-05-18

      You're right, X_PRIMARY needs to be used to get full copy and paste support. (I could have sworn that it worked...)

      Unfortunately, this turns out to be surprisingly hard. X_PRIMARY must be managed by an X client program, unlike X_CUT_BUFFER0 which can be manipulated directly by the X server. It may be necessary to run another thread inside XDarwin that connects as an X client and controls X_PRIMARY.

       
      • Greg Parker

        Greg Parker - 2001-05-18

        Okay, now I'm confused. I think I've found a relatively simple way to add X_PRIMARY support, but with the current CVS code cut&paste works unchanged. If it breaks again I'll add X_PRIMARY, but maybe it's not necessary after all.

         
        • Anonymous - 2001-07-30

          Judging by the date of the last post in this thread I'm guessing you're already aware but just in case...  With the XDarwin 1.0a1 applied to my XFree86 4.1 installation quartz to x11 copy and paste does not seem to work.  x11 to quartz works brilliantly though.  Might just be an irregularity of my setup if its working for other people.

           
          • Greg Parker

            Greg Parker - 2001-08-05

            Strange. It still works fine for me; I can copy from Terminal.app and paste into xterm and XEmacs. Both real and fake mouse buttons work.

             
          • Don MacQueen

            Don MacQueen - 2001-08-07

            Here's another strange example.
            In Excel in Classic mode copy some cells. Try to use middle button to paste into Xemacs. Doesn't work. Go to Eudora (the OS X beta version), open a new text document, paste there (from Excel). It pastes. Then select and copy what was just pasted. Go back to Xemacs and try pasting with middle button. It works.  (but end-of-line convention is different, so still have to replace all Ctrl-M with newline) Go figure.

             
    • Dennis Haag

      Dennis Haag - 2001-08-07

      I have also noticed that cut and paste works fine from OS X apps but not from Classic mode apps. My current workaround is to copy from classic, paste into OS X app (textedit) and then recopy from OS X and paste into XDarwin. Messy, but it has worked for me.

       
      • Finlay Dobbie

        Finlay Dobbie - 2001-08-10

        classic copy/paste is a bit weird in all respects, I'm sure I read that the Mozilla team were experiencing a bug in their carbon app where if the pasteboard was already filled with classic content cut/copy would freeze up for about 30 seconds or so. hmm. very, very odd.

         

Log in to post a comment.

Get latest updates about Open Source Projects, Conferences and News.

Sign up for the SourceForge newsletter:





No, thanks