Mac OS 10.2 and Xemacs Problems

Greg Howes
2002-09-06
2002-09-06
  • Greg Howes

    Greg Howes - 2002-09-06

    I tried to post this message already, but something strange happened; so if it appears twice, please forgive me.

    I have not kept up with the latest upgrades of Xfree86 and XDarwin for some time, but since I was upgrading to OS 10.2 (Jaguar),  I was compelled to upgrade because the old Xfree86 4.1.0 version I had didn't seem to like OS 10.2.

    Now I have gotten Xfree86 4.2.0 up and running with the 4.2.0.1 patch, but the new Xfree86 or the new Mac OS has clobbered my version of Xemacs.  I was running Xfree86 4.1.0 with an older version of XDarwin.  A port of Xemacs--21.2-b46 with a patch by Parker worked beautifully (a few bugs, but nothing important to me).  Now, with 10.2 installed and Xfree86 4.2.0, Xemacs seems not to be working.  I tried a newer port by Chris Roberts from the GNU Mas OS X Public Archive for Xemacs--21.4.3, but it suffers the same problems as the older port, so I think OS 10.2 may be the culprit.

    When I start up, I get this

    [rugby:~] ghowes% xemacs-21.4.3
    dyld: xemacs-21.4.3 Undefined symbols:
    _BC
    _UP
    Trace/BPT trap

    It seems to be some problem with linking to dynamic libraries.  I have had other problems with X applications having library problems under 10.2, so I believe a patch may need to be developed.  Can anyone out there take care of this? 

    I am rather heavily invested in Xemacs, so I would love to get it working again soon.

    Thanks,
    Greg Howes

     
    • Greg Parker

      Greg Parker - 2002-09-06

      Those symbols are supposed to be in the curses library, which moved in Jaguar. The fix is to reconfigure and recompile each program that's not working, or download a new binary that's been compiled on 10.2.

       

Get latest updates about Open Source Projects, Conferences and News.

Sign up for the SourceForge newsletter:





No, thanks