1.0a2 won't start on 10.0.4 or 10.1

2001-09-26
2001-10-03
  • Nicholas Riley

    Nicholas Riley - 2001-09-26

    I tried upgrading to the 1.0a2 test release (after successfully using the previous one) and everything broke.  I can't get XDarwin to start up at all, now.  I started on 10.0.4, but when it didn't work, I thought maybe it was better tested on 10.1, so I upgraded to 10.1.  Nope, still broken.  (If SourceForge has it on their compile farm, I gather I can talk about 10.1 :-)

    Here's what it does (on 10.1 now).

    [p2:8] /Applications/XDarwin.app/Contents/MacOS%./XDarwin

    This is a pre-release version of XFree86, and is not supported in any
    way.  Bugs may be reported to XFree86@XFree86.Org and patches submitted
    to fixes@XFree86.Org.  Before reporting bugs in pre-release versions,
    please check the latest version in the XFree86 CVS repository
    (http://www.XFree86.Org/cvs)

    XFree86 Version 4.1.99.1 / X Window System
    (protocol Version 11, revision 0, vendor release 6510)
    Release Date: xx September 2001
            If the server is older than 6-12 months, or if your hardware is
            newer than the above date, look for a newer version before
            reporting problems.  (See http://www.XFree86.Org/FAQ\)
    Operating System: Darwin
    Using keymapping provided in /System/Library/Keyboards/USA.keymapping.
    _XSERVTransmkdir: Owner of /tmp/.X11-unix should be set to root
    2001-09-25 21:27:32.993 XDarwin[715] X client process terminated with status 1.
    Display mode: Rootless Quartz
    Screen 0 added: 1280x1003 @ (0,21)
    Screen 0 placed at X11 coordinate (0,0).
    2001-09-25 21:27:37.995 XDarwin[715] X server thread never quit.

    In the console, I see:

    Unrecognized option: XDarwinStartup
    use: X [:<display>] [option]
    [... list of options ...]

    giving up.
    xinit:  Connection refused (errno 61):  unable to connect to X server
    xinit:  No such process (errno 3):  Server error.

    This is only a problem for local logins, btw; I had set up xdm so I could log in remotely with XDMCP, and that still works.

    What's wrong?  If all else fails, will 1.0a1 run on 10.1?

    --Nicholas (who's smacking himself in the head for doing an OS upgrade in the face of a deadline.  I know better, really.  Sigh.)

     
    • Torrey T. Lyons

      Torrey T. Lyons - 2001-09-26

      Type "which XDarwinStartup" in the Terminal. If it can't find XDarwinStartup, you are in trouble. Most likely this means that you have not set your path correctly to include /usr/X11R6/bin. Check http://mrcla.com/XonX/start.html for instructions on how to do this. XDarwin 1.0a2 is much more reliable in starting up, but the price is that it insists that you have your path set correctly. Previously XDarwin tried to work with you if your path wasn't set correctly.

      On the other hand, if you path is set correctly but XDarwinStartup is not in /usr/X11R6/bin you have somehow hosed your XFree86 installation. You should get a new XDarwinStartup, probably by reinstalling XFree86 4.1.

       
    • Nicholas Riley

      Nicholas Riley - 2001-09-26

      OK, here's what I've got:

      'which XDarwinStartup' gives me /usr/X11R6/bin/XDarwinStartup.

      I don't have physical access to my OS X box right now so I can't test,
      but one possibility might be that I'm not using tcsh, but zsh.  How
      does XDarwin figure out what your path is?  (Is there any way I can
      see what XDarwin is thinking?)

      Thanks,

      --Nicholas

       
      • Dennis Haag

        Dennis Haag - 2001-09-26

        You can run 'echo $PATH' to see what the path is set to. It looks correct or it would give you something like 'XDarwinStartup: Command not found'.

        You may want to add one of the following commands to your shell initilization or .xinitrc file if needed:

        for csh or tcsh:

        if ( "X`echo $path|grep X11R6`" == "X" ) set path=($path /usr/X11R6/bin)

        for sh, zsh, ksh, or bash:

        if [ "X`echo $PATH|grep X11R6`" = "X" ] then
            PATH="${PATH}:/usr/X11R6/bin"
            export PATH
        fi

         
      • Greg Parker

        Greg Parker - 2001-09-26

        XDarwin doesn't figure out what your PATH is. Instead, it just launches a login shell (hopefully zsh, in your case) and uses the path from there. If `which XDarwinStartup` works, your PATH is fine.

        Looks like there's a bad bug in 1.0a2 - it won't work when you double-click it unless you've told it not to run xinitrc. Try running 1.0a2 from the command line: `startx -- -rootless` or `startx -- -fullscreen`.

         
      • Torrey T. Lyons

        Torrey T. Lyons - 2001-09-26

        As it turns out, there is a bug identified by Greg, but it should be a harmless one. One way the bug could rear its ugly head is if X in /usr/X11R6/bin/ is not a symlink to XDarwinStartup. Try "ls -l /usr/X11R6/bin/X*". If X doesn't point to XDarwinStartup, try "cd /usr/X11R6/bin; sudo ln -s XDarwinStartup X".

         
    • Anonymous - 2001-10-03

      I'm victim to the bug that Greg described but I have the correct symlink from X to XDarwinStartup.  The message I see in the console that I believe is significant is "-bash: xinit: command not found"  I presume this is the sort of thing that Greg ment by "it won't work when you double-click it unless you've told it not to run xinitrc"  How do you tell it "not to run xinitrc"?  Everything works fine when I use the startx script.

       
      • Greg Parker

        Greg Parker - 2001-10-03

        XDarwin currently runs xinit from a non-interactive login shell. In the case of bash, it means that .bashrc is *not* read, so the PATH has to be set in one of .bash_profile, .bash_login, or .profile. zsh has a similar problem: XDarwin's startup will read .zlogin but not .zshrc.

         
        • Anonymous - 2001-10-03

          Hmmm... I have my .bash_profile linked to my .bashrc so the environment should be the same correct?

           
          • Greg Parker

            Greg Parker - 2001-10-03

            Yes, that should work. I forgot to mention the first part: XDarwin > 1.0a1 requires that your shell startup scripts add /usr/X11R6/bin to the PATH. This wasn't necessary before. In your case, .bash_profile needs to do this, so adding it to .bashrc should work because of the symlink.

             

Log in to post a comment.

Get latest updates about Open Source Projects, Conferences and News.

Sign up for the SourceForge newsletter:





No, thanks