XDarwin crashes @ startup if internet connect

2002-09-05
2002-09-13
  • Jonathan Tan

    Jonathan Tan - 2002-09-05

    I'm running XDarwin 4.2, with the jaguar xterm patch installed on a QS867, with jaguar.
    funny thing is: when the internet is NOT connected, xDarwin starts up without a problem. after it has started, i can connect to the net, and not have any problems using it.
    however, if i am already connected to the net, then xDarwin starts, takes a long time, and then quits.
    i suspect it wold be wrong to say tt it crashes, coz there is no dialog box from osX saying tt it has crashed. it just quits.
    this used to be annoying when i had a dialup connection. but it wasn't bad.
    but now i've got an always on connection, and tt is just horrible, coz i can never start up xdarwin anymore.
    this used to occur even back in osX.1...  anybody has any ideas?
    thanks. =D

     
    • Patrik Montgomery

      We will need a bit more information before we can help you. Can you try starting XDarwin from the commandline by typing

      startx -- -quartz

      and post what it says? You might have to add /usr/X11R6/bin to your PATH before this will work, something like this in tcsh

      setenv PATH=${PATH}:/usr/X11R6/bin

       
      • Jonathan Tan

        Jonathan Tan - 2002-09-05

        well...

        your very reply was the answer.

        i noticed that you said to do the setenv command within the tcsh shell, so i had to go and change the terminal back to tcsh, as i was using bash, before tt. (simply because in uni tt's wat we use...)
        after changing back to the tcsh shell, i wondered whether that may be the reason for the problem, and tried starting XDarwin, and lo and behold, it started up fine without any problems...

        so it seems tt it is unable to start up in the bash environment when the internet is connected.

        do u still wish for me to send you the output from starting with the above lines?

        thanks for tt. =D

         
        • Patrik Montgomery

          Actually yes, I'd be very interested in finding out what goes wrong as this seems like a bug that would be very hard to replicate. There is also the option in the XDarwin Preferences dialog to set the shell to be used, but the default is to use the user default. If you set this option to force tcsh and then start with bash, what happens then?

           
          • Jonathan Tan

            Jonathan Tan - 2002-09-07

            *wry grin*
            attempting that has given me big problems...
            i did as you asked: i went into XDarwin prefs, and forced it to start up in tcsh mode, then went quit. went back into terminal, and set that to start up in bash.
            then quit that too, and then started up XDarwin. and that crashed again...

            as a matter of fact, i can't even start up XDarwin anymore... i've turned off the modem, thus disconnecting my internet connection entirely, and then when i try to start up in XDarwin, it immediately quits.

            also, i'm unable to start up from the terminal command line...
            all i get, is an error saying command "startx" not found.
            any ideas?
            also, i may need to start looking for a method to kill the preferences, or even uninstall the XDarwin, and install a fresh new one...

            i just remembered that when i installed XDarwin, i was already using bash... maybe that's placed a few files in places where they shouldn't be, thus giving me all these problems...

            how do i uninstall this anyway?

             
            • Patrik Montgomery

              Sorry I trashed your setup - I just wanted to find the error. Torrey has explained how you remove the preferences - if you want to reinstall everything, remove the following directories

              /etc/X11
              /usr/X11R6

              as well as the application XDarwin.app (it's in Applications if you haven't moved it). After this, you'd reinstall XFree86 4.2 and the updates (I think XFree86 4.2.1 is going to be out RSN, btw).

              To add /usr/X11R6/bin to the path in tcsh, you'd type

              setenv PATH=${PATH}:/usr/X11R6/bin

              and this would have to be added to eg .tcshrc to happen every time. To do the same in bash, you'd type (IIRC, and if it's similar enough to ksh...)

              PATH=$PATH:/usr/X11R6/bin
              export PATH

              (yes, two commands) and those lines added to .bashrc

               
              • Jonathan Tan

                Jonathan Tan - 2002-09-09

                don't worry. =D

                sides... here's something interesting that has occurred after ur new info. =D

                i've been trying to do the setenv PATH command that you have up there in tcsh, but even after doing it, or placing it in the .tcshrc file, it still didn't work. then i tried it in the bash shell, and wow, it worked. i could actually get the startx command to work.
                and even more amazing then tt... doing a startx -- -quartz as suggested, actually got XDarwin to start up... with no problems whatsoever.
                i tried to do a simple startx, with no options, but that didn't work.

                now, since i had previously changed the prefs to force tcsh only, i changed the prefs to use whatever it is set as, and tried again, and once again, XDarwin started up from the command line without any problems.

                so basically:
                terminal is set to the bash shell, with the above commands in the .bashrc file.
                XDarwin starts up from command line using -quartz option (what does it do anyway?), but not from application.

                BTW, just in case you're interested, these are the lines that come up when i start up from the command line...

                _XSERVTransmkdir: Owner of /tmp/.X11-unix should be set to root
                Display mode: Rootless Quartz
                Screen 0 added: 1280x1003 @ (0,21)
                Screen 0 placed at X11 coordinate (0,0).
                cat: /Users/kriston/.Xauthority: No such file or directory
                xterm:  fatal IO error 32 (Broken pipe) or KillClient on X server ":0.0"
                xterm:  fatal IO error 32 (Broken pipe) or KillClient on X server ":0.0"
                xinit:  connection to X server lost.

                thanks. =D
                let me know if there are any other things u want me to try.
                jon

                 
                • Torrey T. Lyons

                  Torrey T. Lyons - 2002-09-09

                  You are mixing apples and oranges a bit here. Launching XDarwin from the command line requires that you have your path set correctly (as you now do). When you launch from the command line, however, the XDarwin shell preferences do not matter. You already have a shell running and XDarwin does not start one.

                  On the other hand if you launch from the Finder, setting your path is not necessary. This is the easiest and "just works" for most people. If this does not work you have something unusual in your shell's startup files (.bashrc, etc.). If you want to find out what is going wrong when starting from the Finder, you need to look at the console log as I mentioned in my other message. The Console application is in /Applications/Utilities. If you run this and post everything from the time XDarwin starts till it quits we can see if we can help you with that as well.

                   
                  • Jonathan Tan

                    Jonathan Tan - 2002-09-10

                    okie...
                    i think i get it now. =)

                    and i got terminal & console mixed up. *whoops*

                    at any rate, here's my console output... =)

                    -------------------------------

                    2002-09-10 23:27:58.106 XDarwin[455]
                    XDarwin 1.1

                    XFree86 Version 4.2.0 / X Window System
                    (protocol Version 11, revision 0, vendor release 6600)
                    Release Date: 18 January 2002
                        If the server is older than 6-12 months, or if your hardware is
                        newer than the above date, look for a newer version before
                        reporting problems.  (See http://www.XFree86.Org/FAQ\)
                    Operating System: Darwin
                    Using keymapping provided in /System/Library/Keyboards/USA.keymapping.
                    Display mode: Rootless Quartz
                    Screen 0 added: 1280x1003 @ (0,21)
                    Screen 0 placed at X11 coordinate (0,0).
                    Warning: no access to tty (Inappropriate ioctl for device).
                    Thus no job control in this shell.
                    /Applications/XDarwin.app/Contents/Resources/startXClients: exec: xinit: not found
                    2002-09-10 23:27:59.526 XDarwin[455] X client process terminated with status 127.
                    Quitting XDarwin...

                    -------------------------------

                    any help will be nice. =)
                    thanks. =)
                    jon

                     
                    • Torrey T. Lyons

                      Torrey T. Lyons - 2002-09-11

                      Your problem is:

                      /Applications/XDarwin.app/Contents/Resources/startXClients: exec: xinit: not found

                      This is likely because of some changes you have made to the preferences. By default the startup preferences add /usr/X11R6/bin to your path. If you have turned this off or changed what is added to your path, xinit will not be found. As I mentioned earlier, to clear your preferences, quit  XDarwin and then type "defaults delete org.xfree86.XDarwin" in the Terminal window.

                       
                      • Jonathan Tan

                        Jonathan Tan - 2002-09-13

                        well. i did wat u suggested, and voila, XDarwin application opens without any problems. =D

                        thanks very much, u 2 guys have been great help!=)

                         
    • Torrey T. Lyons

      Torrey T. Lyons - 2002-09-07

      You can delete your XDarwin preferences by removing ~/Library/Preferences/org.xfree86.XDarwin.plist. The following command should also work:

      defaults delete org.xfree86.XDarwin

      To diagnose what the problem is when starting XDarwin from the Finder, you need to post the entire console log (from the Console utility) from time you start XDarwin till it quits.

      >also, i'm unable to start up from the terminal command line...
      all i get, is an error saying command "startx" not found.
      any ideas?

      Yes, this means you don't have /usr/X11R6/bin in your path.

       

Log in to post a comment.

Get latest updates about Open Source Projects, Conferences and News.

Sign up for the SourceForge newsletter:

JavaScript is required for this form.





No, thanks