#102 Pure Darwin problem.

closed-fixed
X server (105)
7
2001-11-07
2001-10-08
Anonymous
No

I downloaded Darwin/PPC 1.4.1.

The Darwin 1.4.1 contains XFree86.

I installed Darwin on PowerBook G4.

I typed "startx" on console.

But ,X server is frozen at startup.

Any idea?

---
root# startx

This is a pre-release version of XFree86, and is
not supported in any
way. Bugs may be reported to
XFree86@XFree86.Org and patches submitted
to fixes@XFree86.Org. Before reporting bugs in
pre-release versions,
please check the latest version in the XFree86 CVS
repository
(http://www.XFree86.Org/cvs)

XFree86 Version 4.1.99.1 / X Window System
(protocol Version 11, revision 0, vendor release
6510)
Release Date: xx September 2001
If the server is older than 6-12 months, or if
your hardware is
newer than the above date, look for a newer
version before
reporting problems. (See http://
www.XFree86.Org/FAQ)
Operating System: Darwin
Using keymapping provided in /System/Library/
Keyboards/USA.keymapping.
Display mode: IOKit

Discussion

  • Torrey T. Lyons

    Torrey T. Lyons - 2001-10-10

    Logged In: YES
    user_id=133579

    My guess would be that you didn't install the 3rd party drivers that are packaged separately from Darwin 1.4.1 for licensing reasons. See http://www.opensource.apple.com/projects/darwin/1.4/release.html for more info. The ATI driver in particular is needed by XFree86 to talk to the display.

    On the other hand it could be that you have discovered a bug in the XFree86 distribution included with Darwin 1.4.1. (It is pretty up to date.) I haven't had a chance to install the Darwin 1.4.1 distribution, but I do plan to try it out soon.

     
  • Nobody/Anonymous

    Logged In: NO

    Thanks!

    I downloaded and installed 3rd party drivers.
    But,X does not start yet.
    The X is frozen at "Display mode:IOKit" line.

     
  • Torrey T. Lyons

    Torrey T. Lyons - 2001-10-18

    Logged In: YES
    user_id=133579

    This could possibly be related to the building on Mac OS X 10.0.x and running on Mac OS X 10.1 problem. I still have to install Darwin 1.4.1 and test this. In any case, it is a known issue that XFree86 will not run in IOKit mode on Darwin 1.4.x if it was built on Darwin 1.3.x. (Unfortuately all the precompiled binaries we distribute here have been built on Darwin 1.3.x/Mac OS X 10.0.x.) One work around if this is the problem is to build XFree86 for yourself.

     
  • Torrey T. Lyons

    Torrey T. Lyons - 2001-10-18
    • priority: 5 --> 7
    • assigned_to: nobody --> torrey
     
  • Torrey T. Lyons

    Torrey T. Lyons - 2001-11-07
    • status: open --> closed-fixed
     
  • Torrey T. Lyons

    Torrey T. Lyons - 2001-11-07

    Logged In: YES
    user_id=133579

    This is fixed in XDarwin 1.0.4 by requiring that you download the version that is appropriate for the version of DArwin you are running. For Darwin 1.3 (Mac OS X 10.0) you will want XDarwin 1.0.4.0. For Darwin 1.4 (Mac OS X 10.1) you will want XDarwin 1.0.4.1. For XFree86 4.2, there will be two releases made available so users can pick the appropriate version.

     

Log in to post a comment.

Get latest updates about Open Source Projects, Conferences and News.

Sign up for the SourceForge newsletter:





No, thanks