Hi list,

I trawled through the mail archives but didn't have any luck find anything to resolve $subject .. I'm generating Tomcat connector configuration dynamically by inserting sections like this:

...
        <insert path="/Server[@*]/Service[@name]" position="under">
          <![CDATA[
          <Connector
            port="@{port.http}"
            maxThreads="1024"
            minSpareThreads="25"
            maxSpareThreads="75"
            enableLookups="false"
            redirectPort="443"
            acceptCount="100"
            connectionTimeout="20000"
            compression="on"
            compressionMinSize="2048"
            noCompressionUserAgents="Opera,Netscape"
            compressableMimeType="text/html,text/plain,text/css,text/xml,text/javascript,application/x-javascript"
            disableUploadTimeout="true"
            proxyPort="80" />
          ]]>
        </insert>

Unfortunately xmltask seems to be treating commented out sections as text and escaping any angle brackets found within:

      <!--
      &amp;lt;Cluster className="org.apache.catalina.ha.tcp.SimpleTcpCluster"/&amp;gt;
      -->
...
    <!-- You should set jvmRoute to support load-balancing via AJP ie :
    &amp;lt;Engine name="Catalina" defaultHost="localhost" jvmRoute="jvm1"&amp;gt;
    -->
...
        <!--
        &amp;lt;Valve className="org.apache.catalina.authenticator.SingleSignOn" /&amp;gt;
        -->

Would anyone have an explanation or workaround for this behaviour ?

thanks