#1 configure fails to detect incorrect motif library

closed-fixed
nobody
None
5
2007-08-25
2007-07-24
No

The current version of XmBlackBerry seems to require OpenMotif 2.3 or later, but the autoconf scripts don't know this, and seem to think it's going to work with lesstif or an earlier openmotif. The user then gets errors on some XmVa functions which are completely opaque and do not lead them to realize that they need a newer/different Motif library.

Discussion

  • Rick Scott

    Rick Scott - 2007-08-25
    • status: open --> closed-fixed
     
  • Rick Scott

    Rick Scott - 2007-08-25

    Logged In: YES
    user_id=54972
    Originator: NO

    ./configure now complains if the XmVaCreate* functions are not available.

     

Log in to post a comment.