Catastrophic Failure

  • Nobody/Anonymous

    Upgrading to latest version results in following error: System Error &H8000FFFF (-2147418113).  Catastrophic Failure

    The error went away when I un-installed the XL Toolbox, however it surfaced again on re-installation.

    Any recommendations?

  • Anonymous - 2010-03-20


    does this error occur only with the latest version (2.66)? Not with previous versions?

    What versions of Excel and Windows are you using? Do you have plenty of memory available on your computer? Do you open workbooks on a network share?

    If you have time, I'd recommend to turn on the logging feature of the XL Toolbox:

    Start the registry editor by pressing WIN+R, then typing "regedit" and ENTER.

    Locate the following key: HKEY_CURRENT_USER\Software\VB and VBA Program Settings\Daniel's XL Toolbox\Prefs

    Insert a new String Value ("Edit"-"New"-"String Value"); name the value "Logging" and set the value to "1".

    Install the XL Toolbox and start Excel.

    After the crash, open your application data folder: Press WIN+R, enter "%appdata%\Microsoft\Addins\XLToolbox". In this folder, you will find a file "xltoolbox_log.txt". You can inspect this file and send it to me at  x l t o o l b o x (at) g m x . n e t.

    This catastrophic failure has been reported by the Excel gurus on the web, e.g. - but people seem to be clueless what it means.


  • Nobody/Anonymous

    Yes it only happens after I installed v2.66. I do ot have any memory or network share issues that you mentioned. I will send you the log file soon

  • Bruce Bradbury

    Bruce Bradbury - 2011-01-19

    I'm getting the same problem. v2.73a on Windows XP, Excel 2007.  I tried the logging option, but no log files appeared. As well as the error messages I get a box "Cannot run the macro 'XLTB_Ribbon_onLoad'. The macro may not be available in this workbook or all macros may be disabled".
    PS it was working a few days ago before the latest round of windows updates.

  • Anonymous - 2011-01-20

    Hi Bruce,

    I'm sorry you're experiencing problems. This one is a hard one to solve. Have you tried uninstalling, then reinstalling the Toolbox?

    It's strange that there is no log file, I just checked the functionality on my machine, it works as expected. Hm.

    Since you received a message about macros being potentially disabled - is it possible that one of the Windows updates changed the security settings?


  • Nobody/Anonymous

    I reinstalled the toolbox, and the spreadsheet openned fine (and I got the introductory xltoolbox window). However, I just tried again (accessing my machine via a remote terminal session) and the problem has reappeared! I'll check again when in the office tomorrow.

  • Nobody/Anonymous

    Now this is weird. It  is working fine when I'm at the machine. Why would accessing via remote terminal services make a difference?



Cancel  Add attachments

Get latest updates about Open Source Projects, Conferences and News.

Sign up for the SourceForge newsletter:

No, thanks