Hi Victor,

2008/6/27, Victor Escutia <victor_escutia@yahoo.com>:
Hi All,

It's me again, i posted the topic:
        [Xins-users] Help with configuration, error: java.lang.NoSuchMethodError: org.apache.tools.ant.types.Resource.getMagicNumber([B)I but as i didn't know how to post in the same thread, decided to wait for the next post for show my thankfulness for the masters of XINS (because it was a environment configuration problem in my lap) and to expose another doubt. In fact, are 2:

1. I want to report a bug, but i don't know if it is. When i change de web-path in the <impl> tag just to change the exposition web path of the web service,  everything is fine but the generated examples, specifically in the test form, it show the url without taking in count the web-path attribute.

The paths of the API used for the test forms are defined in the  environments.xml file.

2. And the most important and urgent for me, is that i'm implementing a web service solution in my company, and i have some clients in .NET platform that want to communicate with my webservice. I'm doing the last connection testings, and i'm having problems to connect with a csharp client, in case of java clients is all right and behave excellent, but when i want to generate a .net csharp webservice client, i didn't get it to work. This is what i've found (is the same result with the samples or my custom api implementation):

In a Visual Studio 2005 project, i add a web reference, i put, in the url field of the wizard, for example:
and push the go button, after a while, the wizard finds the wsdl descriptor and shows the name of the service, and even the exposed methods declarations with its corresponding description, but the first rare thing that happens is that in the section Web Services Availables in this URL, shows nothing, just:
             1 service found:
but don't show the name of the service, also in the Name of Web Reference, shows "localhost" if i build the war with all other tasks with xins all, and shows "WebReference" if i build the war the same manner but with the wsdl.endpoint property set to, ie.: in a build.properties. In your usr guide, you recomend to do this just to allow other platforms to connect to a xins webservice ("You can then use this generated file in the Web Services client sush as C#, Visual Basic, PHP, Perl").

Here I'm a bit confused with the "if"s. Can you rephrase?

When i push the Add Reference button, the VS adds a reference of my webservice under the Web Reference folder. But when i tray to find the imported objects or the service, these simply don't exist. Even if i double click the web reference object under the Web Reference folder, in the Object browser, dont appear any reference object.

I've tried other web services examples published in the net, and i add the reference in Visual Studio and it creates the reference objects without no problems, but i don't understand why it happens with my xins web service.

When developing the WSDL I've used the WS-I Basic Profile as reference and used several technics to verify that it is compliant with the standard. Unfornately I'm not a C# or VB specialist. The best thing to fix this problem is that you look at the WSDL generated by XINS and the ones you mention work and try to detect the different which make VB and C# not to recognize everything. If possible to compare don't use WSDL generated from C# or VB but from other Java or PHP Web Services frameworks.

Hope that helps,