On Thu, 20 Mar 2008 15:16:47 +0000,
Darren Salt <linux@youmustbejoking.demon.co.uk> wrote
>I demand that JD may or may not have written...
>
>> I have the following xine and xine related RPMS installed:
>
>> $ rpm -qa | grep xine
>> gxine-0.5.11-14.fc7
>> xine-lib-1.1.10.1-1.fc7.1
>[snip]
>> System is FC7 with latest updates on AMD 64 cpu, and ATI Radeon 9600
>> graphics, and 2GB ram and oodles of disk space.
>
>> At anyrate, if I run gxine it starts up and after I get the gui, it crashes
>> immediately and kills the X server and I have to re-login.
>
>That says that there's some bugginess in the X server or one of its driver
>modules.
>
>> However, if I run it via gdb, no problems at all - it comes up, I can play
>> a movie and I exit gxine and all is well.
>
>That suggests that something uninitialised is being used. BTW, why are you
>using opengl? xv should be fine on that hardware.
>
>Version numbers of relevant installed X server/driver packages, may help.

The xorg server is
xorg-x11-server-Xorg-1.3.0.0-16.fc7
The driver is:
xorg-x11-drv-ati-6.6.3-4.fc7

P.S: I will try to install the ATI/AMD driver 
     ati-driver-installer-8-3-x86.x86_64
     to see if it will make any difference

>
>> I am not having this problem with xine itself. Only gxine.
>
>That's a bit... strange. It does say that startup differences play a part,
>though.

I think it also says there is a timing issue - this is usually the case when
a problem will manifest when debugging is off, but will not manifest when
debugging is on. I have seen this often also in real-time systems development.