Had read that xine was working on Windows.  Was uanble to find a copy of the executable, so I decided to download the source code and attempt to compile it myself.  I'm using the latest version of mingw and have msys on my system.  When I do a ./configure in msys, I get an error:

checking for pthread_create in -lpthread... no
configure: error: pthread needed

I did a search on the web for pthread and found a site describing how to download it from redhat and to install pthreadGC1.dll to Windows\System, pthread.h, sched.h and semaphore.h to \mingw\include and libpthreadGC1.a to \mingw\lib  Am still getting the same error.  The configure file can't seem to find the pthread library.  I also tried configure with the option to not use the pthread package (--with-pthread-prefix=no) and that didn't seem to work either.  Anyone know a fix for this?

Are there any special instructions or help for compiling using mingw on Windows XP?  The configure file doesn't appear to work right out of the box.



Call Anyone, Anytime, Anywhere in the World - FREE!
Free Internet calling from NetZero Voice
Visit http://www.netzerovoice.com today!