Hi red, I'm sorry your review on my code took 4 hours of your time !!
As you said, you took an hard look on it.
I've just viewed your new design, I'll do my best. It's the first time for
me working in team, today I learned a big lesson on how different ideas can
be, inside two different brains. Definitely they are the same but...
Coming back to work, I have some things to say.
I agree with you that the names I used for classes were not completely
clear; we can also rename PAQFile into PAQVirtualFile to finally resolve
Then, PAQFile::onInvalidateFileManipulator() is noted "called from
PAQFile", you ment PAQSolidFile?
The idea of using a PAQSolidFileManipulator is very good!! However I have
not clear how the PAQSolidFile::lockFile() will work. Will it remove all
manipulators and build only one manipulator write-enabled? Or will it
destroy every PAQFile object previously created without notify the application?
Anyway, I suggest the manipulator class to be derived from IIAbstractFile
class PAQSolidFileManipulator : public IIAbstractFile
I'll post it on the list too..
Get latest updates about Open Source Projects, Conferences and News.