#361 Libreoffice GUI opening up when it should not

open-fixed
margotc
9
2012-06-11
2012-03-01
No

When Xena processes a Office file it is opening up a graphical interface for LibreOffice when it should not. This seems to be a problem specific to the machine it is run on as this did not occur on the old development machines but does on the new ones. When testing this please use the 6.0.0 release files to confirm that this behaviour is present on the machine first.

Discussion

  • Terry O'Neill

    Terry O'Neill - 2012-03-01

    Assigned to margot as she has fixed this with a "-headless" option. Note that there are other options that we do not have such as "-nofirststartwizard" which may be worth looking into. Also note that there is possibly more to this so probably would be a good idea to test with an old development machine as well to try to nail down other differences.

     
  • margotc

    margotc - 2012-03-01

    I think it's a good idea to investigate these options during testing. I will look into the switches suggested. I would like to test the -headless option on the older machines before other testing occurs.

     
  • margotc

    margotc - 2012-03-01

    Some specific testing scenarios are required to test this.

     
  • margotc

    margotc - 2012-03-01
    • assigned_to: margotc --> kirtic
    • status: open --> open-fixed
     
  • margotc

    margotc - 2012-04-03

    I have also found that libreoffice splash screen executes on advanced normalisation causing normalisation failure. The code I was testing this on is the current testing branch.

     
  • margotc

    margotc - 2012-04-04
    • priority: 5 --> 9
     
  • margotc

    margotc - 2012-04-19

    I've tested this extensively with updated code base and i am satisfied it's ok now. I think the re-emergence of the problem was due to a stale local code base and this bug should now be closed. Please feel free to respond. I'll leave the actual closing of the job to you at your discretion.

     
  • Kirti Chennareddy

    • assigned_to: kirtic --> margotc
     
  • Kirti Chennareddy

    Tested with Xena 6.0.0 on
    Fedora 16 with Libreoffice 3.4.4 and 3.4.5 - Works fine with no GUI
    Kororaa 14 with Libreoffice 3.4.4 - Works fine with no GUI
    WinXp with Libreoffice 3.4.4 - Libreoffice GUI comes up when Xena starts normalizing a doc, if I close the GUI normalizing fails with "No connection error" but if I leave the GUI normalizing completes successfully.

    I have found that as long as the soffice.exe and soffice.bin processes are running, it normalizes fine. Closing the GUI is killing the processes and the normalizing fails with a no connection error.

     
  • margotc

    margotc - 2012-04-23
    • status: open-fixed --> closed-fixed
     
  • Kirti Chennareddy

    While I was testing the installers for DPR, I found that Libreoffice GUI issue still exists.

    It could be OS specific. I am now working on the newly built machine which has Ubuntu and Libreoffice 3.5.

    Below is the behaviour,

    XENA:

    Make sure no processes related to libreoffice are running.
    Open Xena
    Select a word doc and click on Normalize
    Libreoffice GUI comes up
    1. If you clos the GUI, then the Normalization fails with error “connection refused”
    2. If you don’t close the GUI, then the normalization completes successfully.
    On the viewer, clicking on the open in libreoffice.org brings up the GUI, but again, if you don’t close the GUI it will open the file, else will not respond.

    DPR:

    Restart PC and process a office doc through the PF stage, the Libreoffice GUi come up,
    1. If you clos the GUI, then the Normalization fails with error “connection refused”
    2. If you don’t close the GUI, then the normalization completes successfully.

    QA viewer - Clicking on ‘open in libreoffice’ does not respond. On closing the QA window, it throws a Null pointer exception error.

     
  • Kirti Chennareddy

    • status: closed-fixed --> open-fixed
     
  • Michael Carden

    Michael Carden - 2012-06-07
    • assigned_to: margotc --> terryoneill
    • status: open-fixed --> open
     
  • Kirti Chennareddy

    • assigned_to: terryoneill --> margotc
    • status: open --> open-fixed
     
  • Kirti Chennareddy

    Problem was with the DPR-Openjdk and DPR-oracleJava builds. Tested with the new builds for openjdk and oraclejava and is working fine.
    Tested all other builds with word documents normalizing and it is working fine.

     

Log in to post a comment.