installation problems

Help
Sakame
2007-02-14
2016-10-18
  • Sakame

    Sakame - 2007-02-14

    I'm currently using suse 10.2. Following the installation instruction for what is needed for xdrawchem, i have installed openbabel 2.0.2 (no installation problems) on my computer and all necessary package. I ran the ./configure command and everything was ok then i use the make command and this error message appears:

    application.moc.cpp:12:2: error: #error "The header file 'application.h' doesn't include <QObject>."
    application.moc.cpp:166: error: ‘const QMetaObject ApplicationWindow::staticMetaObject’ is not a static member of ‘class ApplicationWindow’
    application.moc.cpp:166: error: variable ‘const QMetaObject ApplicationWindow::staticMetaObject’ has initializer but incomplete type
    application.moc.cpp:171: error: prototype for ‘const QMetaObject* ApplicationWindow::metaObject() const’ does not match any in class ‘ApplicationWindow’
    application.h:32: error: candidate is: virtual QMetaObject* ApplicationWindow::metaObject() const
    application.moc.cpp:171: error: ‘const QMetaObject* ApplicationWindow::metaObject() const’ cannot be overloaded
    application.h:32: error: with ‘virtual QMetaObject* ApplicationWindow::metaObject() const’
    application.moc.cpp: In member function ‘const QMetaObject* ApplicationWindow::metaObject() const’:
    application.moc.cpp:173: error: cannot convert ‘QMetaObject* (*)()’ to ‘const QMetaObject*’ in return
    application.moc.cpp: At global scope:
    application.moc.cpp:176: error: no ‘void* ApplicationWindow::qt_metacast(const char*)’ member function declared in class ‘ApplicationWindow’
    application.moc.cpp: In member function ‘void* ApplicationWindow::qt_metacast(const char*)’:
    application.moc.cpp:181: error: ‘qt_metacast’ is not a member of ‘QMainWindow’
    application.moc.cpp: At global scope:
    application.moc.cpp:184: error: ‘int ApplicationWindow::qt_metacall’ is not a static member of ‘class ApplicationWindow’
    application.moc.cpp:184: error: incomplete type ‘QMetaObject’ used in nested name specifier
    application.moc.cpp:184: error: expected primary-expression before ‘int’
    application.moc.cpp:184: error: expected primary-expression before ‘void’
    application.moc.cpp:184: error: initializer expression list treated as compound expression
    application.moc.cpp:185: error: expected ‘,’ or ‘;’ before ‘{’ token
    make[2]: *** [application.moc.o] Error 1
    make[2]: Leaving directory `/home/thomas/programmes/xdrawchem-1.9.9/xdrawchem'
    make[1]: *** [all-recursive] Error 1
    make[1]: Leaving directory `/home/thomas/programmes/xdrawchem-1.9.9'
    make: *** [all] Error 2

    So thinking that it was due to the Qt program i installed the last version (4.2.2) but the same error message appeared.
    Do you know where the problem can be and how to resolve it?

     
  • murray

    murray - 2011-07-26

    I'm trying to install also, but the install.txt file is not clear where to type "./configure" after installing openbabel and build3D. I don't have much experience with GNU software.
    Thanks!

     
    • Paul

      Paul - 2016-10-18

      You should type ./configure in console.

       

Log in to post a comment.

Get latest updates about Open Source Projects, Conferences and News.

Sign up for the SourceForge newsletter:

JavaScript is required for this form.





No, thanks