Aaron Anderson - 2003-11-06

I setup XCHM with TTF and it looks (and reads) 100% better than with the default fonts and I thought I would share my settings with others who are interested.

Here is my setup:
Redhat 9.0 with dev rpms
xchm 0.8.7 src
wxGTK-2.4.2 src

Install windows TTF fonts in windows.
Here is how I did it:
1 From windows partition copied c:\WINDOWS\fonts to ~/.fonts
2. converted all font files to lower case with a script
3. cd ~/.fonts
4. ran /usr/bin/ttmkfdir
5. ran /usr/X11/bin/mkfontdir
6. ran /usr/sbin/chkfontpath -a ~/.fonts
7. restarted xserver
8. ran gnome-font-properties to set new fonts (I prefer Tahoma)

Compile wxGTK with GTK2.0:
rm config.cache
./configure --with-gtk --enable-gtk2 --with-opengl --enable-unicode
make install

compile xCHM
make install

Then you can setup xCHM to use the windows fonts (Tahoma) which makes xchm look very close to the windows help file reader.