#119 Random square after certain characters

open-wont-fix
nobody
None
5
2006-02-08
2006-01-30
Anonymous
No

When using certain characters like ' " and !, a square
appears in other people's IRC clients two lines after
the original line with punctuation. I've tried
switching character sets to WINDOWS-1252 and UTF-8 -
the problem still exists.

It's definately there, as if you try a /me command, the
square breaks this.

Discussion

  • C L

    C L - 2006-02-04

    Logged In: YES
    user_id=1425757

    We need more information to be able to reproduce this. What clients are the
    other people using? What encoding?

     
  • Olly

    Olly - 2006-02-04

    Logged In: YES
    user_id=1439912

    People have noticed this with mIRC on Windows, I've noticed
    it with Chatzilla on OSX, and others have reported it with
    Chatzilla on Windows.

    They are all using UTF-8 as far as I'm aware.

    I have tried UTF-8 and WINDOWS-1252 in X-Chat Aqua, neither
    make any difference.

    The square is this character: 

     
  • C L

    C L - 2006-02-04

    Logged In: YES
    user_id=1425757

    Come to #xca on undernet, we might be able to do some testing.

     
  • Steve Green

    Steve Green - 2006-02-04

    Logged In: YES
    user_id=208673

    This is fixed for the next release

     
  • Steve Green

    Steve Green - 2006-02-04
    • status: open --> closed-fixed
     
  • C L

    C L - 2006-02-07

    Logged In: YES
    user_id=1425757

    Actually, this is not our bug, and thus won't be fixed by us. Thanks to Olly's
    cooperation, we traced the problem to the Audio Hijack haxie; we'll contact its
    developer and let him handle it. For anyone who is experiencing this problem,
    the workaround is to use the APE manager to disable the "Instant Hijack Server"
    module in XCA.

     
  • C L

    C L - 2006-02-07
    • status: closed-fixed --> closed-wont-fix
     
  • C L

    C L - 2006-02-08
    • status: closed-wont-fix --> open-wont-fix
     
  • C L

    C L - 2006-02-08

    Logged In: YES
    user_id=1425757

    Update: it does not seem to be caused by Hijack, after all. If anyone else is
    seeing this bug, please get in contact; so far, only one user is able to reproduce
    it.

     

Log in to post a comment.