#2550 /etc/odbc* zeroed out during updatenode

2.8.2
wont-fix
5
2014-12-24
2012-01-23
No

xCAT Version: Version 2.6.10 (svn r11351, built Thu Jan 5 03:38:26 EST 2012)

updatenode service -V -S installp_bundle=xCATaixSN71 rpm_flags="-Uvh --replacepkgs --nodeps"

After running this command the /etc/odbc* zero out.

[c250mgrs11-pvt][/]> xdsh service -v ls -l /etc/odbc*
c250f14c02ap01: -rw-r--r-- 1 root system 44 Nov 03 15:57 /etc/odbc.ini
c250f14c02ap01: -rw-r--r-- 1 root system 122 Nov 03 15:57 /etc/odbcinst.ini

[c250mgrs11-pvt][/]> updatenode service -V -S installp_bundle=xCATaixSN71 rpm_flags="-Uvh --replacepkgs --nodeps"
Running command on c250mgrs11-pvt: /usr/sbin/lsnim -a location -Z 1114A_71BSN_lpp_source 2>/dev/null 2>&1

Running command on c250mgrs11-pvt: /usr/sbin/lsnim -a location -Z xCATaixSN71 2>/dev/null 2>&1

Running command on c250mgrs11-pvt: cat /install/nim/installp_bundle/xCATaixSN71.bnd 2>&1

Running command on c250mgrs11-pvt: /bin/hostname 2>&1

Running command on c250mgrs11-pvt: ifconfig -a| grep "inet" 2>&1

Performing software maintenance operations. This could take a while.

Running command on c250mgrs11-pvt: cp /tmp/installp_file-1327293861 /install/nim/lpp_source/1114A_71BSN_lpp_source; chmod 444 //install/nim/lpp_source/1114A_71BSN_lpp_source/installp_file-1327293861 2>&1

Running command on c250mgrs11-pvt: exportfs -i /install/nim/lpp_source/1114A_71BSN_lpp_source 2>&1

Running command on c250mgrs11-pvt: /bin/chmod -R +r /install/nim/lpp_source/1114A_71BSN_lpp_source 2>&1

Running command: mkdir -m 644 -p /xcatmnt; mount c250mgrs11-pvt:/install/nim/lpp_source/1114A_71BSN_lpp_source /xcatmnt

Running internal xCAT command: xdsh ...

Running command on c250mgrs11-pvt: /bin/hostname 2>&1

Running command on c250mgrs11-pvt: ifconfig -a| grep "inet" 2>&1

Running: '/usr/sbin/installp -d /xcatmnt/installp/ppc -agQX -f /xcatmnt/installp_file-1327293861'.

Running internal xCAT command: xdsh ...

Running command on c250mgrs11-pvt: /bin/hostname 2>&1

Running command on c250mgrs11-pvt: ifconfig -a| grep "inet" 2>&1

Could not run installp command.

c250f14c02ap01: WARNINGS
c250f14c02ap01: --------
c250f14c02ap01: Problems described in this section are not likely to be the source of any
c250f14c02ap01: immediate or serious failures, but further actions may be necessary or
c250f14c02ap01: desired.
c250f14c02ap01: Already Installed
c250f14c02ap01: -----------------
c250f14c02ap01: The number of selected filesets that are either already installed
c250f14c02ap01: or effectively installed through superseding filesets is 72. See
c250f14c02ap01: the summaries at the end of this installation for details.
c250f14c02ap01:
c250f14c02ap01: NOTE: Base level filesets may be reinstalled using the "Force"
c250f14c02ap01: option (-F flag), or they may be removed, using the deinstall or
c250f14c02ap01: "Remove Software Products" facility (-u flag), and then reinstalled.
c250f14c02ap01:
c250f14c02ap01: << End of Warning Section >>

c250f14c02ap01: +-----------------------------------------------------------------------------+
c250f14c02ap01: Pre-installation Verification...
c250f14c02ap01: +-----------------------------------------------------------------------------+
c250f14c02ap01: Verifying selections...done
c250f14c02ap01: Verifying requisites...done
c250f14c02ap01: Results...
c250f14c02ap01: FAILURES
c250f14c02ap01: --------
c250f14c02ap01: Filesets listed in this section failed pre-installation verification
c250f14c02ap01: and will not be installed.
c250f14c02ap01: Requisite Failures
c250f14c02ap01: ------------------
c250f14c02ap01: SELECTED FILESETS: The following is a list of filesets that you asked to
c250f14c02ap01: install. They cannot be installed until all of their requisite filesets
c250f14c02ap01: are also installed. See subsequent lists for details of requisites.
c250f14c02ap01:
c250f14c02ap01: bos.loc.iso.et_EE 7.1.0.0 # Base System Locale ISO Code ...
c250f14c02ap01: bos.loc.iso.hr_HR 7.1.0.0 # Base System Locale ISO Code ...
c250f14c02ap01: bos.loc.iso.ja_JP 7.1.0.15 # Base System Locale ISO Code ...
c250f14c02ap01: bos.loc.iso.lt_LT 7.1.0.0 # Base System Locale ISO Code ...
c250f14c02ap01: bos.loc.iso.lv_LV 7.1.0.0 # Base System Locale ISO Code ...
c250f14c02ap01: bos.loc.iso.mk_MK 7.1.0.0 # Base System Locale ISO Code ...
c250f14c02ap01: bos.loc.iso.ro_RO 7.1.0.0 # Base System Locale ISO Code ...
c250f14c02ap01: bos.loc.iso.sh_SP 7.1.0.0 # Base System Locale ISO Code ...
c250f14c02ap01: bos.loc.iso.sh_YU 7.1.0.0 # Base System Locale ISO Code ...
c250f14c02ap01: bos.loc.iso.sl_SI 7.1.0.0 # Base System Locale ISO Code ...
c250f14c02ap01: bos.loc.iso.sr_SP 7.1.0.0 # Base System Locale ISO Code ...
c250f14c02ap01: bos.loc.iso.sr_YU 7.1.0.0 # Base System Locale ISO Code ...
c250f14c02ap01: MISSING REQUISITES: The following filesets are required by one or more
c250f14c02ap01: of the selected filesets listed above. They are not currently installed
c250f14c02ap01: and could not be found on the installation media.
c250f14c02ap01:
c250f14c02ap01: bos.loc.com.EE 5.3.0.0 # Base Level Fileset
c250f14c02ap01: bos.loc.com.EE 4.1.0.0 # Base Level Fileset
c250f14c02ap01: bos.loc.com.JP 4.1.0.0 # Base Level Fileset
c250f14c02ap01: AVAILABLE REQUISITES: You specified that requisite software should be
c250f14c02ap01: automatically installed. Additional filesets (4) would have been
c250f14c02ap01: installed automatically had the selected filesets passed all requisite
c250f14c02ap01: checks.
c250f14c02ap01:
c250f14c02ap01: << End of Failure Section >>
c250f14c02ap01: +-----------------------------------------------------------------------------+
c250f14c02ap01: BUILDDATE Verification ...
c250f14c02ap01: +-----------------------------------------------------------------------------+
c250f14c02ap01: Verifying build dates...done
c250f14c02ap01: FILESET STATISTICS
c250f14c02ap01: ------------------
c250f14c02ap01: 84 Selected to be installed, of which:
c250f14c02ap01: 12 FAILED pre-installation verification
c250f14c02ap01: 72 Already installed (directly or via superseding filesets)
c250f14c02ap01: ----
c250f14c02ap01: 0 Total to be installed
c250f14c02ap01:
c250f14c02ap01: Pre-installation Failure/Warning Summary
c250f14c02ap01: ----------------------------------------
c250f14c02ap01: Name Level Pre-installation Failure/Warning
c250f14c02ap01: -------------------------------------------------------------------------------
c250f14c02ap01: bos.loc.iso.sr_YU 7.1.0.0 Requisite failure
c250f14c02ap01: bos.loc.iso.sr_SP 7.1.0.0 Requisite failure
c250f14c02ap01: bos.loc.iso.sl_SI 7.1.0.0 Requisite failure
c250f14c02ap01: bos.loc.iso.sh_YU 7.1.0.0 Requisite failure
c250f14c02ap01: bos.loc.iso.sh_SP 7.1.0.0 Requisite failure
c250f14c02ap01: bos.loc.iso.ro_RO 7.1.0.0 Requisite failure
c250f14c02ap01: bos.loc.iso.mk_MK 7.1.0.0 Requisite failure
c250f14c02ap01: bos.loc.iso.lv_LV 7.1.0.0 Requisite failure
c250f14c02ap01: bos.loc.iso.lt_LT 7.1.0.0 Requisite failure
c250f14c02ap01: bos.loc.iso.ja_JP 7.1.0.15 Requisite failure
c250f14c02ap01: bos.loc.iso.hr_HR 7.1.0.0 Requisite failure
c250f14c02ap01: bos.loc.iso.et_EE 7.1.0.0 Requisite failure
c250f14c02ap01: openssl.license 0.9.8.1300 Already superseded by 0.9.8.1800
c250f14c02ap01: openssl.base 0.9.8.1300 Already superseded by 0.9.8.1800
c250f14c02ap01: openssh.msg.en_US 5.4.0.6100 Already superseded by 5.8.0.6101
c250f14c02ap01: openssh.man.en_US 5.4.0.6100 Already superseded by 5.8.0.6101
c250f14c02ap01: openssh.base.server 5.4.0.6100 Already superseded by 5.8.0.6101
c250f14c02ap01: openssh.base.client 5.4.0.6100 Already superseded by 5.8.0.6101
c250f14c02ap01: bos.sysmgt.nim.master 7.1.0.15 Already superseded by 7.1.1.0
c250f14c02ap01: bos.loc.iso.tr_TR 7.1.0.0 Already superseded by 7.1.1.0
c250f14c02ap01: bos.loc.iso.sv_SE 7.1.0.0 Already superseded by 7.1.1.0
c250f14c02ap01: bos.loc.iso.sq_AL 7.1.0.0 Already superseded by 7.1.1.0
c250f14c02ap01: bos.loc.iso.no_NO 7.1.0.0 Already superseded by 7.1.1.0
c250f14c02ap01: bos.loc.iso.nl_NL 7.1.0.0 Already superseded by 7.1.1.0
c250f14c02ap01: bos.loc.iso.nl_BE 7.1.0.0 Already superseded by 7.1.1.0
c250f14c02ap01: bos.loc.iso.ms_MY 7.1.0.0 Already superseded by 7.1.1.0
c250f14c02ap01: bos.loc.iso.it_IT 7.1.0.0 Already superseded by 7.1.1.0
c250f14c02ap01: bos.loc.iso.it_CH 7.1.0.0 Already superseded by 7.1.1.0
c250f14c02ap01: bos.loc.iso.is_IS 7.1.0.0 Already superseded by 7.1.1.0
c250f14c02ap01: bos.loc.iso.id_ID 7.1.0.0 Already superseded by 7.1.1.0
c250f14c02ap01: bos.loc.iso.fr_LU 7.1.0.0 Already superseded by 7.1.1.0
c250f14c02ap01: bos.loc.iso.fr_FR 7.1.0.0 Already superseded by 7.1.1.0
c250f14c02ap01: bos.loc.iso.fr_CH 7.1.0.0 Already superseded by 7.1.1.0
c250f14c02ap01: bos.loc.iso.fr_CA 7.1.0.0 Already superseded by 7.1.1.0
c250f14c02ap01: bos.loc.iso.fr_BE 7.1.0.0 Already superseded by 7.1.1.0
c250f14c02ap01: bos.loc.iso.fi_FI 7.1.0.0 Already superseded by 7.1.1.0
c250f14c02ap01: bos.loc.iso.en_ZA 7.1.0.0 Already superseded by 7.1.1.0
c250f14c02ap01: bos.loc.iso.en_US 7.1.0.0 Already superseded by 7.1.1.0
c250f14c02ap01: bos.loc.iso.en_SG 7.1.0.0 Already superseded by 7.1.1.0
c250f14c02ap01: bos.loc.iso.en_PH 7.1.0.0 Already superseded by 7.1.1.0
c250f14c02ap01: bos.loc.iso.en_NZ 7.1.0.0 Already superseded by 7.1.1.0
c250f14c02ap01: bos.loc.iso.en_IN 7.1.0.0 Already superseded by 7.1.1.0
c250f14c02ap01: bos.loc.iso.en_IE 7.1.0.0 Already superseded by 7.1.1.0
c250f14c02ap01: bos.loc.iso.en_HK 7.1.0.0 Already superseded by 7.1.1.0
c250f14c02ap01: bos.loc.iso.en_GB 7.1.0.0 Already superseded by 7.1.1.0
c250f14c02ap01: bos.loc.iso.en_CA 7.1.0.0 Already superseded by 7.1.1.0
c250f14c02ap01: bos.loc.iso.en_BE 7.1.0.0 Already superseded by 7.1.1.0
c250f14c02ap01: bos.loc.iso.en_AU 7.1.0.0 Already superseded by 7.1.1.0
c250f14c02ap01: bos.loc.iso.el_GR 7.1.0.0 Already superseded by 7.1.1.0
c250f14c02ap01: bos.loc.iso.de_LU 7.1.0.0 Already superseded by 7.1.1.0
c250f14c02ap01: bos.loc.iso.de_DE 7.1.0.0 Already superseded by 7.1.1.0
c250f14c02ap01: bos.loc.iso.de_CH 7.1.0.0 Already superseded by 7.1.1.0
c250f14c02ap01: bos.loc.iso.de_AT 7.1.0.0 Already superseded by 7.1.1.0
c250f14c02ap01: bos.loc.iso.da_DK 7.1.0.0 Already superseded by 7.1.1.0
c250f14c02ap01: bos.adt.syscalls 7.1.0.15 Already superseded by 7.1.1.0
c250f14c02ap01: bos.adt.debug 7.1.0.15 Already superseded by 7.1.1.0
c250f14c02ap01: expect.base 5.42.1.0 Already installed
c250f14c02ap01: expect.man.en_US 5.42.1.0 Already installed
c250f14c02ap01: tcl.base 8.4.7.0 Already installed
c250f14c02ap01: tcl.man.en_US 8.4.7.0 Already installed
c250f14c02ap01: tk.base 8.4.7.0 Already installed
c250f14c02ap01: tk.man.en_US 8.4.7.0 Already installed
c250f14c02ap01: devices.tmiscsw.rte 7.1.0.0 Already installed
c250f14c02ap01: devices.tmiscsw.rte 7.1.0.16 Already installed
c250f14c02ap01: bos.sysmgt.nim.spot 7.1.0.15 Already installed
c250f14c02ap01: bos.rte.serv_aid 7.1.0.15 Already installed
c250f14c02ap01: LoadL.resmgr.full 5.1.0.0 Already installed
c250f14c02ap01: LoadL.resmgr.msg.en_US 5.1.0.0 Already installed
c250f14c02ap01: LoadL.resmgr.loc.license 5.1.0.0 Already installed
c250f14c02ap01: LoadL.scheduler.full 5.1.0.0 Already installed
c250f14c02ap01: LoadL.scheduler.so 5.1.0.0 Already installed
c250f14c02ap01: LoadL.scheduler.msg.en_US 5.1.0.0 Already installed
c250f14c02ap01: LoadL.scheduler.loc.licen 5.1.0.0 Already installed
c250f14c02ap01: LoadL.scheduler.webui 5.1.0.0 Already installed
c250f14c02ap01: ppe.man 1.1.0.0 Already installed
c250f14c02ap01: ppe.loc.license 1.1.0.0 Already installed
c250f14c02ap01: ppe.rte 1.1.0.0 Already installed
c250f14c02ap01: ppe.openshmem 1.0.0.0 Already installed
c250f14c02ap01: devices.chrp.IBM.HFI.rte 1.1.0.0 Already installed
c250f14c02ap01: devices.common.IBM.hfi.rt 1.1.0.0 Already installed
c250f14c02ap01: devices.msg.en_US.chrp.IB 1.1.0.0 Already installed
c250f14c02ap01: devices.msg.en_US.common. 1.1.0.0 Already installed
c250f14c02ap01: devices.common.IBM.ml 1.5.1.0 Already installed
c250f14c02ap01: devices.msg.en_US.common. 1.5.1.0 Already installed
Running command: /usr/sbin/updtvpkg

Running internal xCAT command: xdsh ...

Running command on c250mgrs11-pvt: /bin/hostname 2>&1

Running command on c250mgrs11-pvt: ifconfig -a| grep "inet" 2>&1

Running: 'cd /xcatmnt/RPMS/ppc; /usr/bin/rpm -Uvh --replacepkgs --nodeps popt rsync bash conserver curl expat fping libxml2 net-snmp-5.4.2.1-3 net-snmp-devel net-snmp-perl openslp-xcat perl-Crypt-SSLeay perl-DBD-SQLite perl-DBI perl-Digest-HMAC perl-Digest-MD5 perl-Digest-SHA-5 perl-Digest-SHA1 perl-Expect perl-IO-Stty perl-IO-Tty perl-Net-DNS perl-Net-IP perl-Net-Telnet perl-version-0.82-2 perl-Net_SSLeay.pm-1.30-3 perl-IO-Socket-SSL unixODBC perl-DBD-DB2 perl-DBD-Pg perl-DBD-mysql perl-xCAT xCAT-client xCAT-server xCAT-rmc xCATsn* 2>/dev/null'.

Running internal xCAT command: xdsh ...

Running command on c250mgrs11-pvt: /bin/hostname 2>&1

Running command on c250mgrs11-pvt: ifconfig -a| grep "inet" 2>&1

c250f14c02ap01: popt ##################################################
c250f14c02ap01: rsync ##################################################
c250f14c02ap01: bash ##################################################
c250f14c02ap01: conserver ##################################################
c250f14c02ap01: curl ##################################################
c250f14c02ap01: expat ##################################################
c250f14c02ap01: fping ##################################################
c250f14c02ap01: libxml2 ##################################################
c250f14c02ap01: net-snmp ##################################################
c250f14c02ap01: net-snmp-devel ##################################################
c250f14c02ap01: net-snmp-perl ##################################################
c250f14c02ap01: openslp-xcat ##################################################
c250f14c02ap01: perl-Crypt-SSLeay ##################################################
c250f14c02ap01: perl-DBD-SQLite ##################################################
c250f14c02ap01: perl-DBI ##################################################
c250f14c02ap01: perl-Digest-HMAC ##################################################
c250f14c02ap01: perl-Digest-MD5 ##################################################
c250f14c02ap01: perl-Digest-SHA ##################################################
c250f14c02ap01: perl-Digest-SHA1 ##################################################
c250f14c02ap01: perl-Expect ##################################################
c250f14c02ap01: perl-IO-Stty ##################################################
c250f14c02ap01: perl-IO-Tty ##################################################
c250f14c02ap01: perl-Net-DNS ##################################################
c250f14c02ap01: perl-Net-IP ##################################################
c250f14c02ap01: perl-Net-Telnet ##################################################
c250f14c02ap01: perl-version ##################################################
c250f14c02ap01: perl-Net_SSLeay.pm ##################################################
c250f14c02ap01: perl-IO-Socket-SSL ##################################################
c250f14c02ap01: unixODBC ##################################################
c250f14c02ap01: perl-DBD-DB2 ##################################################
c250f14c02ap01: perl-DBD-Pg ##################################################
c250f14c02ap01: perl-DBD-mysql ##################################################
c250f14c02ap01: perl-xCAT ##################################################restartxcatd invoked by root.
c250f14c02ap01: 0513-044 The xcatd Subsystem was requested to stop.
c250f14c02ap01: 0513-059 The xcatd Subsystem has been started. Subsystem PID is 8781922.
c250f14c02ap01:
c250f14c02ap01: xCAT-client ##################################################
c250f14c02ap01: xCAT-server ##################################################restartxcatd invoked by root.
c250f14c02ap01: 0513-044 The xcatd Subsystem was requested to stop.
c250f14c02ap01: 0513-059 The xcatd Subsystem has been started. Subsystem PID is 12320888.
c250f14c02ap01:
c250f14c02ap01: xCAT-rmc ##################################################restartxcatd invoked by root.
c250f14c02ap01: 0513-044 The xcatd Subsystem was requested to stop.
c250f14c02ap01: 0513-059 The xcatd Subsystem has been started. Subsystem PID is 8126514.
c250f14c02ap01:
c250f14c02ap01: xCATsn ##################################################

Running command: umount -f /xcatmnt

Running internal xCAT command: xdsh ...

Running command on c250mgrs11-pvt: /bin/hostname 2>&1

Running command on c250mgrs11-pvt: ifconfig -a| grep "inet" 2>&1

Running command on c250mgrs11-pvt: rm -f /install/nim/lpp_source/1114A_71BSN_lpp_source/installp_file-1327293861; rm -f /tmp/installp_file-1327293861 2>&1

Running command on c250mgrs11-pvt: exportfs -u -F /install/nim/lpp_source/1114A_71BSN_lpp_source 2>&1

Error: One or more errors occured while updating node software.

[c250mgrs11-pvt][/]> xdsh service -v ls -l /etc/odbc*
c250f14c02ap01: -rw-r--r-- 1 root system 2 Jul 15 2009 /etc/odbc.ini
c250f14c02ap01: -rw-r--r-- 1 root system 1 Jul 15 2009 /etc/odbcinst.ini

[c250mgrs11-pvt][/]> xdcp service -v /etc/odbc* /etc/

[c250mgrs11-pvt][/]> xdsh service -v ls -l /etc/odbc*
c250f14c02ap01: -rw-r--r-- 1 root system 44 Jan 22 23:49 /etc/odbc.ini
c250f14c02ap01: -rw-r--r-- 1 root system 122 Jan 22 23:49 /etc/odbcinst.ini
[c250mgrs11-pvt][/]>

Discussion

  • Kerry Bosworth

    Kerry Bosworth - 2012-01-23

    I spoke to the xCAT team this morning and they have some ideas on how to address this. In the short term we should use the -P in the command to re-run the odbc postscript. They will look at other alternatives for the rpm command.

     
  • Lissa Valletta

    Lissa Valletta - 2012-01-24

    To work around this problem, and it will only affect you if you are running LoadLeveler using DB2 on the servicenodes, then do the following:

    xdsh <servicenodes> /opt/xcat/bin db2sqlsetup -C -o
    to set these files back up for LoadLeveler to be able to access the database.

     
  • Norm Nott

    Norm Nott - 2012-02-15

    The rmnimimage -u command has a similar problem. It has been fixed in xCAT 2.7 and 2.6.11.

    However, the updatenode command will require some extra design/coding since each node would have to be checked to see if the rpm is already installed. We will most likely have to create a script that we can run on the nodes that will check for the rpms and only install the ones that are not already installed. - TBD

    This may not make 2.7.

     
  • Bruce

    Bruce - 2012-03-15

    Moving to 2.7.1

     
  • Guang Cheng Li

    Guang Cheng Li - 2012-04-13

    I do not think we will fix this problem in 2.7.1, moving it out to 2.7.2.

     
  • Norm Nott

    Norm Nott - 2012-08-03

    Note: the script we create to run on the nodes will also have to handle the case where the user specifies "update_all". In this case the code should update all software that is installed - but not install anything else. This will also require that the local script determine what is installed on the node.

     
  • Bruce

    Bruce - 2012-08-04

    Since this will take quite a bit of work to do this correctly and we will be implementing part of yum on aix, i'm not sure we should fix this at all at this point. We have a lot of other priority work.

     
  • Norm Nott

    Norm Nott - 2013-01-22
    • milestone: 2.8 --> 2.8.1
     
  • Norm Nott

    Norm Nott - 2013-03-26
    • milestone: 2.8.1 --> 2.8.2
     
  • Norm Nott

    Norm Nott - 2013-06-25
    • status: open --> wont-fix
     

Get latest updates about Open Source Projects, Conferences and News.

Sign up for the SourceForge newsletter:





No, thanks