Anyone upgraded to Hardy

Help
lingenfr
2008-04-24
2013-04-08
  • lingenfr

    lingenfr - 2008-04-24

    Has anyone running mythbuntu as a backend upgraded to Hardy? If so, is xbmcmythtv still functioning?

     
    • Ron Kellam

      Ron Kellam - 2008-04-27

      I'm not running mythbuntu, but a normal ubuntu machine that has followed a fiesty->gutsy->hardy upgrade path.

      Somewhere in the upgrade to Hardy, the XBMC mythtv plugin & script stopped communicating with the backend.  I thought it was the protocol change as MythTV 0.21 got rolled out, so upgraded the plugin/scripts with latest from CVS - still no luck.

      It wasn't until I got WireShark to sniff out the xbox<->mysql interaction and saw mysql returning an error of 1251 that I made some progress.  A google of "mysql mythtv error 1251" turned up some info at "http://www.xbox-linux.org/wiki/MythTV_on_Xebian_HOWTO".

      The following fixed the problem and got the plugin and scripts running again.  I'd guess that mysql got upgraded in the hardy upgrade, and somewhere along the way some privileges got lost.  Anyway, I'm a happy chappy again, and the WAF is recovering.

      Cheers,
      ronkinoz.
      -------------------

      # mysql -u root -p -h localhost
      mysql>  GRANT ALL PRIVILEGES ON *.* TO 'mythtv'@'192.168.0.10' IDENTIFIED BY 'mythtv' WITH GRANT OPTION;
      mysql> quit;

      If you have a recent version of MythTV on the backend with MySQL 5.0 installed, you may see the following error when connecting:

      ERROR 1251: Client does not support authentication protocol requested by server; consider upgrading MySQL client

      You can get around this by updating the password to the old style by running

      mysql> UPDATE mysql.user SET Password = OLD_PASSWORD('mythtv') WHERE User = 'mythtv';

      Alternately, if that doesn't work, try:

      mysql> SET PASSWORD FOR 'live'@'xbox_host' = OLD_PASSWORD('secretmagicpasswd');

       
    • lingenfr

      lingenfr - 2008-04-27

      Thanks for the feedback. I guess I will upgrade this week.

       
    • David Teirney

      David Teirney - 2008-05-03

      Everytime I've had MySQL upgraded I've had to set the password for the mythtv user to use the OLD_PASSWORD algoritm. I think it's because the Python libraries don't support the newer authentication model.

      The following worked for me after upgrading to Ubunty Hardy Heron.

      # mysql -u root -p
      mysql> SET PASSWORD FOR 'mythtv' = OLD_PASSWORD('secret');

       
    • lingenfr

      lingenfr - 2008-05-03

      FWIW, I uprgraded to hardy and did not have to do anything. Since upgrading, I can run the mythtv functionality in xbmc just fine. Previously it was constantly buffering unless I used mplayer instead of the dvdplayer. With the backend upgraded to hardy both the 04-06 and 04-20 t3ch svn builds seem to work like a champ. I am hoping that t3ch does another build this weekend. I understand that elepus has implemented a guide which I would like to see. Hopefully in a few months the xbmc work will be caught up with this script.

       
    • lingenfr

      lingenfr - 2008-05-04

      I spoke too soon. Still getting the buffering.

       
    • lingenfr

      lingenfr - 2008-05-09

      I have previously been installing the T3CH builds by overwriting only newer files. Bad idea. WHen I went back and overwrote all, I got the Guide option under Watch TV. I suppose that I need to look at some different skins, but suffice it to say that this script with something like tippo's mod to xTV is better for my needs. It is too bad that xTV as a skins suxors. If PM III had a button on the home page that launched the xbmcmythtv script, I wouldn't worry about the xbmc functionality.

       

Log in to post a comment.