MythTV 0.21 Working

Help
2008-03-25
2013-04-08
  • Philip Ward

    Philip Ward - 2008-03-25

    I have managed to modify xbmcmythtv 0.20.34 so that it works with MythTV 0.21.
    Not everything is working or tested (free and used space is currently broken) but you can watch recorded shows and see upcoming recordings.

    The only file I had to modify was mythtv.py. You can get the modified version at http://staff.stir.ac.uk/p.g.ward/mythtv.py

    Any maintainers listening in please let me know if you want a proper patch, or feel free to take my modified file and use it.

    I'll see what I can do over the next few days to fix other issues.

    Hope you find it useful.

    Phil.

     
    • lingenfr

      lingenfr - 2008-03-25

      Glad to see other folks who are capable engaging with the scripts. Does livetv work?

       
    • Philip Ward

      Philip Ward - 2008-03-25

      Yes, although I just tried it, and for some weird reason it picked the wrong audio stream by default, and hung when I tried to change it. Your mileage may vary.

      Please report anything you see still broken. No promises but I'll see what I can do.

      Phil.

       
    • mfarley

      mfarley - 2008-03-26

      Phil -- I think I speak for us all when I say: You sir, are a saint!  You have saved my family, my living room, and my life.  Many cheers :)

       
    • lingenfr

      lingenfr - 2008-03-26

      To be clear, I tried xbmcmythtv 36a. I replaced the mythtv.py with Phil's version. I entered my settings and no matter what I tried, no livetv. Everything else seemed to work which was an improvement, but no livetv. Did someone get livetv to work? I don't have a problem going back to 34. Thanks.

       
    • David Teirney

      David Teirney - 2008-03-26

      @lingenfr - I patched the 0.20.36a mythtv.py script using the changes that Philip made to the 0.20.34 script.

      No luck getting Live TV to work with it though. I can post it somewhere on the net if you want to try it anyway.

      Most of the rest of the script appears to work with some missing bits of information.

      I'm new to Python and don't really know anything about how this script interacts with MythTV and XBMC... If anyone manages to get anything else working I'd be happy to patch the changes into the 36a scripts.

      The new T3CH release of XBMC was just released with some more notes about mythtv in the release notes so I'm going to try and see what other changes were made at the weekend.

       
    • lingenfr

      lingenfr - 2008-03-26

      In another thread, I mentioned that I have loaded the latest T3CH. You can go in to livetv, it brings up the channel listing with the current shows, but when you select a channel it locks up the xbox tighter than a ducks arse.

       
    • Philip Ward

      Philip Ward - 2008-03-26

      Yep. I've seen that as well. I'll leave my 0.20.34 mythtv.py available for those running the latest release, but I've now got the latest from CVS. LiveTV sets the backend recording, but locks up trying to view the recording. I'll have a go this evening at it.

      Phil.

       
    • Philip Ward

      Philip Ward - 2008-03-26

      This evening I grabbed the latest 0.20.36a from CVS and have managed to get it to behave with Myth Backend 0.21.
      Watching LiveTV and recordings works for me. I've even fixed the disk usage display (protocol forty shifts total and used up an element in the array).

      My 0.20.34 mythtv.py is still where I left it. Mythtv.py for 0.20.36a (which I guess should be changed to 0.21.0a) is at http://staff.stir.ac.uk/p.g.ward/0.20.36a/mythtv.py.

      If anyone here has a myth backend older than 0.21 it would be good to hear if any of the changes have broken it for you.

      Any official maintainers here feel free to incorporate the changes in a new release.

      Phil.

       
    • Philip Ward

      Philip Ward - 2008-03-26

      Just in case it's important, I probably should have mentioned that I'm using the very latest T3CH build of XBMC.

      Phil.

       
    • lingenfr

      lingenfr - 2008-03-27

      phil, didn't work for me. if the record livetv is checked, it acts like it wants to start and then it asks me if i want to stop recording. Regardless of whether i click yes or no, it doesn't start. if i uncheck record livetv it tells me playlist aborted too many failed items. if i check the button for use dvdplayer for livetv, it acts like it wants to start then nothing. I have multiple tuners in my backend.

       
    • Philip Ward

      Philip Ward - 2008-03-27

      Can you switch on verbose debugging in default.py? Towards the top of the file you set the debug level. You just need to comment out the current level, and uncomment the level you want.

      You can then grab the debug log and email it to philNOSPAMward@bigfoot.com.

      No promises that I can sort it, but I'll take a look.

      Phil.

       
    • Teresa

      Teresa - 2008-03-27

      Are you using the latest files from CVS?  If you sort by date you can see some files were updated within the last 4 months.  I don't believe they were updated in the bundle so you have to download those files by hand.  I have all of xbmcmythtv working by only changing the mythtv.py similarly to what others have done.  I previously worked on the fixes for liveTV but I only fixed where Record live tv is Unchecked and didn't look at getting it working when it was checked.  I am also using XBMC from 2008-03-23 but I don't know if that makes a difference.

       
    • lingenfr

      lingenfr - 2008-03-27

      No, I used the latest compiled SVN version from T3CH. I tried again with the latest stable version from T3CH. Still no joy. I have multiple xboxs, so I tried phil's mythtv.py on another one that (I think) was built with the tweaked xbmc/xbmcmythtv that frooby made available a month or so ago and it worked fine. My plan was just to copy that over to my other boxes tonight, but before I do, I will turn on verbose debug and run it through the paces again. I looked at the xbmc.log's last night. I saw some DNS errors that seemed to be what folks have been talking about in the latest xbmc builds. I saw some other errors that looked skin related. I will send phil the log this evening. Just want to be clear that I have a working config, so I will scale back the whining. I should be able to get out of the doghouse with SO and kids.

       
    • lingenfr

      lingenfr - 2008-03-28

      phil, unfortunately about once per week, i need to be reminded that i am a moron. verbose debug told me that i needed to correct my paths. now all is grand. thanks.

       
    • frooby

      frooby - 2008-03-29

      I have updated cvs for 0.21 protocol 40. Haven't tested though. Should have finished updating my backend this afternoon and will test then.

       
    • lingenfr

      lingenfr - 2008-03-29

      everything works for me except the program guide. when i click program guide, nothing happens.There are a lot of errors in the log about Proj Mayhem skin missing pieces, but nothing else.

       
    • Floris van de Kamer

      Oh my, It give me hope! after upgrading to mythtv 0.21 i couldn't use the script anymore. so this solution sounds nice. but after upgrading xbmc, getting the script and using the mythtv.py i got an error logging into the database. what could be the problem? other linux-pc's can using mythfrontend. xmbc with "myth://" works also, but the script not. please help me (and my family...)

      Greetings Floris

       
    • lingenfr

      lingenfr - 2008-05-11
       
    • Floris van de Kamer

      didn't work for me... the last of my xbmc.log is
      23:19:48 M: 29757440   DEBUG: Alloc resources: 45.45ms (0.01 ms skin load, 22.48 ms preload)

      23:19:51 M: 29683712   DEBUG: Activating window ID: 13001

      23:19:51 M: 29683712   DEBUG: Checking if window ID 13001 is locked.

      23:19:51 M: 34029568   DEBUG: Alloc resources: 15.18ms (0.00 ms skin load, 0.41 ms preload)

      23:19:55 M: 34029568   DEBUG: CApplication::OnKey: 167 pressed, action is 4

      23:20:02 M: 34058240   DEBUG: CApplication::OnKey: 167 pressed, action is 4

      23:20:03 M: 34062336   DEBUG: CApplication::OnKey: 167 pressed, action is 4

      23:20:04 M: 34062336   DEBUG: CApplication::OnKey: 11 pressed, action is 7

      23:20:04 M: 34050048    INFO: Loading skin file: DialogOK.xml

      23:20:04 M: 34050048   DEBUG: Load DialogOK.xml: 65.16ms (63.02 ms xml load)

      23:20:04 M: 34037760   DEBUG: Alloc resources: 23.30ms (0.00 ms skin load, 0.16 ms preload)

      23:20:06 M: 33660928   DEBUG: CApplication::OnKey: 11 pressed, action is 7

      23:20:06 M: 34062336    INFO: Traceback (most recent call last):

      23:20:06 M: 34062336    INFO:   File "Q:\scripts\xbmcmythtv\mythtvsettings.py", line 287, in testSettings

      23:20:06 M: 34058240    INFO:     db = getInstance( mythtv.Database )

      23:20:06 M: 34058240    INFO:   File "Q:\scripts\xbmcmythtv\singleton.py", line 50, in getInstance

      23:20:06 M: 34058240    INFO:     if not obj.testActive():

      23:20:06 M: 34058240    INFO:   File "Q:\scripts\xbmcmythtv\mythtv.py", line 2314, in testActive

      23:20:06 M: 34045952    INFO:     del self.conn

      23:20:06 M: 34045952    INFO: AttributeError: conn

      with myth://mythtv:(password)@192.168.1.64 it works like it should do. exept that i can't fastforward etc. But i want the xbmcmythtv working, becouse it was much better. And i use the same username and password for mysql.
      the only thing i can see is the 'coming up shows'. now with the xbmcmythtv script. anyone any idea?

      tnx Floris

       
  • cap9qd

    cap9qd - 2009-10-09

    Phil…You have just made my day; I may be about a year behind everyone else in getting my xbox up and working with 0.21 but you just made my week!  I want to buy you a beer….send me your paypal.

     

Log in to post a comment.

Get latest updates about Open Source Projects, Conferences and News.

Sign up for the SourceForge newsletter:





No, thanks