#1 compilation errors with gcc 3.3

closed
keuleu
5
2003-05-05
2003-05-02
No

I get compilation errors while compiling either 6.0, 6.6a,
6.7 or CVS sources with gcc 3.3 on SuSE 8.2.
Everything runs OK with gcc 3.2 on SuSE 8.1.

The first error happens in file deinterlace.c : invalid
argument in 'pcmpgtw'

Is there a patch for gcc 3.3 ?

Thanks.

Michel

Discussion

  • keuleu

    keuleu - 2003-05-02

    Logged In: YES
    user_id=199970

    Looks like inline assembly rules have changed with gcc 3.3.
    Unfortunately there isn't any patch yet available to fix this.

     
  • keuleu

    keuleu - 2003-05-02
    • assigned_to: nobody --> keuleu
     
  • Catherine Michel

    Logged In: YES
    user_id=769842

    If it can help you, I can tell that Xine-lib-0.9 from sourceforge
    compiles with exactly the same error, but that version 1beta
    compiles OK.

    Michel.

     
  • keuleu

    keuleu - 2003-05-05
    • status: open --> closed
     
  • keuleu

    keuleu - 2003-05-05

    Logged In: YES
    user_id=199970

    Yes this definitively helps!
    Latest CVS compiles now fine with gcc-3.3!

    Cheers,
    keuleu

     
  • Catherine Michel

    Logged In: YES
    user_id=769842

    OK thanks, it compiles fine but I get compile errors with the
    plugin !

    Michel

     

Get latest updates about Open Source Projects, Conferences and News.

Sign up for the SourceForge newsletter:





No, thanks