Downloading x264vfw 64bit?

Help
Simsari
2014-08-03
2014-11-16
  • Simsari

    Simsari - 2014-08-03

    How can I download the 64bit version of x264?
    Please help, it's not working with Bandicam since I've bought a new 64bit PC! :(
    Sincerely
    Simsari

     
    Last edit: Simsari 2014-08-07
  • BugMaster

    BugMaster - 2014-08-03

    To download 64-bit version instead of 32-bit which is suggested by download button (sourceforge allow only one such button on main page without creating my own site) on main page you should go to the Files section and there navigate to the x264vfw64 directory and choose what version you want to download.

     
  • Simsari

    Simsari - 2014-08-03

    Thank you very much! :)

    But Bandicam still doesn't show the x264 codec. I reinstalled Bandicam and rebooted the PC. Nothing works. The strange thing is that I recorded games with x264 2 days ago. Yesterday it is gone. Now it seems, that I can't install it anymore... :(
    The virus protection isn't the problem.
    Any ideas?
    Sincerely
    Simsari

     
    Last edit: Simsari 2014-08-07
  • BugMaster

    BugMaster - 2014-08-03

    Try to download 64-bit VirtualDub and check if x264vfw64 show up there. If it show up in 64-bit VitrualDub and not in Bandicam than it is the problem with Bandicam and you should ask for the help from their support. Also are you sure that your Bandicam app is 64-bit (64-bit OS allow to run both 32 and 64-bit apps) and not 32-bit (in which case you need normal 32-bit x264vfw and not x264vfw64)?

     
  • Simsari

    Simsari - 2014-08-03

    Also in Virtualdub 64-bit the x264 codec isn't showing up. I really have no idea, why my x264 codec is gone and don't work again... :(

    EDIT: Bandicam supports 32- and 64-bit

    Thanks for replying! :)
    ~Simsari

     
    Last edit: Simsari 2014-08-03
  • BugMaster

    BugMaster - 2014-08-04

    What is your OS version? If it is Windows 8.x than you try to look at this topic.

     
  • Simsari

    Simsari - 2014-08-04

    Thank you for the linked topic! :)
    I copied the x264vfw.dll and the x264vfw64.dll to the system32 and sysWOW64 folders. It seems to not work for me...
    I think the problem is that I don't get the reply of you.
    May you explain to me, what you mean with "Try to change path to dll in registry"?

    PS: I'm using Windows 8.1 ;)
    ~Simsari

     
    Last edit: Simsari 2014-08-04
  • BugMaster

    BugMaster - 2014-08-04

    It means exactly what is written i.e. you change the value in Windows registry (with regedit.exe). But before you will mess up with registry be warned that you do this all on your own risk (it is better to understand what you changing in registry). Also can you copy/paste the output of the "fsutil.exe 8dot3name query" and "fsutil.exe 8dot3name query c:" (I suppose you installed x264vfw to disk c: here) commands executed in cmd.exe with admin rights? It will help me to guess/understand why normal installer doesn't work for you (and some other people with Windows 8.x).

     
  • Simsari

    Simsari - 2014-08-05

    I changed the values in regedit.exe exactly how you descriped it, but it still doesn't show up in VDUB and BCAM.
    My outputs are:
    fsutil.exe 8dot3name query: 2
    fsutil.exe 8dot3name query c: access denied

    ~Simsari

     
    Last edit: Simsari 2014-08-05
  • BugMaster

    BugMaster - 2014-08-05

    Do you run it with admin rights (Run as administrator)? Because "access denied" hints otherwise. It should say something like:

    The volume state for Disable8dot3 is 0 (8dot3 name creation is enabled).
    The registry state of NtfsDisable8dot3NameCreation is 2, the default (Volume level setting).
    Based on the above two settings, 8dot3 name creation is enabled on C:.
    

    If it says something other than you can try to enable short file names with "fsutil.exe behavior set disable8dot3 0" and restart (not sure if it needed), after which install x264vfw and x264vfw64 normally with installer.

    UPDATE: not sure may be command line for enabling should be "fsutil.exe 8dot3name set 0" and not the one with behavior.

     
    Last edit: BugMaster 2014-08-05
  • Simsari

    Simsari - 2014-08-06

    It says the same thing like yours, but don't work either...
    Do you have an idea?
    Thank you for more replies :)
    ~Simsari

     
  • BugMaster

    BugMaster - 2014-08-06

    I am out of ideas. If "fsutil.exe 8dot3name set 0" and reinstalling (full uninstall and install) of x264vfw do not work than I don't know what to do. Looks like for some reason Windows 8.x hates x264vfw :(

    P.S. It works without problems here with Windows 7

     
  • Simsari

    Simsari - 2014-08-07

    Thank you very much for your constant help! :)
    It seems like I must use another codec
    ~Simsari

    EDIT: I simply typed "fsutil.exe 8dot3name set 0" in cmd.exe, fully deinstalled x264 and x264 64bit (together with register settings and dll. files in system32 and sysWOW64), restarted the PC and reinstalled x264 and x264 64bit! :)
    Now it does show up in Bandicam! :D

    Thank you very much (again)
    for the constant help & for solving my problem! :)
    Sincerely
    Simsari

     
    Last edit: Simsari 2014-08-07
  • Simsari

    Simsari - 2014-08-07

    Now Bandicam doesn't show up x264 codec anymore since I used Keep/Accept only YUV 4:4:4. This must be the problem! ;)

    But I know how to fix it now! :D

    Thank you :)
    Sincerely
    Simsari

     
    Last edit: Simsari 2014-08-07
  • BugMaster

    BugMaster - 2014-11-16

    Starting from release 40_2491bm_40895 I updated installer (x264vfw_full) to include both 32-bit and 64-bit versions. Also I changed installer to write dll-files to system directories to fix problems with short path so now this workarounds shouldn't be needed.

     

Get latest updates about Open Source Projects, Conferences and News.

Sign up for the SourceForge newsletter:





No, thanks