Dalton Harvie - 2014-06-25

Hi,

On recent versions (13.04) of wxmaxima running on osx 10.8, when I use the menus to insert a maxima function (say Calculus/integrate, Expression = x + OK) the resulting function does not appear in the command window (although it enters a blank carriage return), nor does it execute. If I type the commands manually, they execute correctly. I tried deleting my ~/.maxima directory, but no difference.

This insert function feature does work on osx 10.8 using some older wxmaxima versions that I still had a dmg file of. Have also tried a newer Maxima 5.31 with these but doesn't make any difference either. Looks to be a wxMaxima bug/incompatibility with 13.04.

Doesn't work in these versions:
wxMaxima 13.04.0 + wxWidgets 2.8.12 + Maxima 5.30.0 from Maxima-5.30.0.dmg - doesn't work.
wxMaxima 13.04.1 + wxWidgets 2.9.5 + Maxima 5.30.0 installed from macports - doesn't work.

Does work in these versions:
wxMaxima 12.08.0 + wxWidgets 2.8.12 + Maxima 5.30.0 from Maxima-5.28.0.dmg - does work.
wxMaxima 0.8.5 + wxWidgets 2.8.11 + Maxima 5.30.0 from wxMaxima-0.8.5-Maxima-5.21.1.dmg - does work.

Thanks for developing this great software.