Beginner - How to install wxHexEditor on Ubuntu 12.04

Help
CoSoCo
2013-02-20
2014-04-02
  • CoSoCo

    CoSoCo - 2013-02-20
    1. I do not find wxHexEditor in Ubuntu Software Center ?
    2. I have read the doc/COMPILE
    3. What do you mean by "install wxWidgets" ?
      I have found several wxWidgets packages in Ubuntu Software Center, but I don't know, what to install ?
    4. Where in Ubuntu file svstem tree should I extract wxHexEditor tar ball ?
     
    Last edit: CoSoCo 2013-02-20
  • Death Knight®

    Death Knight® - 2013-02-23

    Hi CoSoCo.
    Here is my answers;

    1.I don't know. I am not related with Ubuntu. Please mail to "Ubuntu" about why they don't have wxHexEditor at their software center by default.
    2.It's for compiling for yourself but I don't think if you have enough knowledge to do this.
    3.Installing wxWidgets, means, himmm: Installing wxWidgets. :)
    Simply you just need instal wxgtk libraries at ubuntu.
    You can find details at here:
    http://wiki.wxwidgets.org/Installing_and_configuring_under_Ubuntu
    4.Don't know also. I believe you just need pre-compiled binary package of wxHexEditor for ubuntu. Search it on web. Here I find one for you:
    http://www.ubuntuupdates.org/package/getdeb_apps/precise/apps/getdeb/wxhexeditor

     
  • CoSoCo

    CoSoCo - 2013-03-05

    3.Thanks, now I have installed libwxgtk2.8-dev and libwxgtk2.8-dbg

    4a.E.g. wxWidgets is spreaded in /usr/share/doc, /usr/lib/x86_64-linux-gnu/wx
    So I'm not shure if I should extract wxHexEditor tar ball to similar locations before compiling
    4b.Thanks for the link, but the download links do not work :-(
    ... after some days of patience at least "APT INSTALL" now worked :-)

    5.Very nice tool, thanks :-)
    I tried to open device sda or sda1, but nothing happened :-(
    Opening a normal file is working perfect.

     
    Last edit: CoSoCo 2013-03-05
  • CoSoCo

    CoSoCo - 2013-03-05

    Now I tried to compile here:
    me@Ulfuntu:~$ cd Projects/wxHexEditor/
    me@Ulfuntu:~/Projects/wxHexEditor$ make OPTIFLAGS="-fopenmp"
    cd udis86;./autogen.sh
    ./autogen.sh: Zeile 4: autoreconf: Kommando nicht gefunden.
    autogen: autoreconf -i failed.
    make: *** [udis86/libudis86/.libs/libudis86.a] Fehler 1
    me@Ulfuntu:~/Projects/wxHexEditor$

    Any idea, what is missing?

     
    Last edit: CoSoCo 2013-03-05
  • Death Knight®

    Death Knight® - 2013-03-06

    4a You don't need any special folder to compile wxHexEditor.

    1. I don't know why it doesn't working on /dev/sda1.
      Could you try with root account?

    2. Error says that your computer doesn't know where "autoreconf" is. Indeed you need to install autotools, automake and some other libraries too for compiling it from source. Please use apt-get install to installing those tools too. :)

     
  • CoSoCo

    CoSoCo - 2013-03-06

    Thanks again !!
    4a.This question was because I worried if MAKE also copies the resulting build to the right/usual location in the GNU/Linux file system trees. Does it?

    • I could open /dev/sda, /dev/sda1, etc. after "sudo wxHexEditor" from the console. Would be nice to have this facility after starting from the starter icon, maybe wxHE could ask for root password, if attempting to open block devices directly, but never should do nothing without error message.
    • For sda4, only the first 1024 bytes are displayed :-(
    • What is "some other libraries"? I now have successfully installed autotools, automake via Ubuntu Software Center :-)
      Would be nice to explain dependencies more detailed in COMPILE document.
     
    Last edit: CoSoCo 2013-03-06
  • Death Knight®

    Death Knight® - 2013-03-06

    4.a. make command just compiles file and doesn't copies any binary or library to system. You can run wxHexEditor executable without installing. But if you want to install it, you have to issue "make install" command All files need to be removed with "make uninstall" command also.

    *wxHexEditor will ask for root password for changing permission of /dev/sda1 (or similar) for opening/reading it. Also reverts the permission back at closing the file. I am not sure if you are actually using wxHexEditor's trunk version. It's already implemented feature.

    • I don't know why. Might be sda4 is just 1024 byte partition or there is something wrong at code.

    • Indeed wxHexEditor doesn't use any library other than wxWidgets. It uses udis86 and mhash libraries also but they are included to the code. So you don't need to download them. I don't know what other "tools" need for compiling it... Yes It's better to say that but I don't know actually what is required other than autotools/automake. Indeed those tools are counted as standard development packages and available almost all development installation. Indicating it like saying "you need a gcc for compile this tool". So I don't think if it's really required.

    Thanks

     
  • CoSoCo

    CoSoCo - 2013-03-14

    I now retried and see errors again:

    me@Ulfuntu:~/Projects/wxHexEditor$ cd ..
    me@Ulfuntu:~/Projects$ cd ..
    me@Ulfuntu:~$ cd Projects/wxHexEditor/
    me@Ulfuntu:~/Projects/wxHexEditor$ make OPTFLAGS="-fopenmp"
    cd udis86;./autogen.sh
    Can't exec "libtoolize": Datei oder Verzeichnis nicht gefunden at /usr/bin/autoreconf line 196.
    Use of uninitialized value in pattern match (m//) at /usr/bin/autoreconf line 196.
    autoreconf: Entering directory `.'
    autoreconf: configure.ac: not using Gettext
    autoreconf: running: aclocal --force -I m4
    autoreconf: configure.ac: tracing
    autoreconf: configure.ac: not using Libtool
    autoreconf: running: /usr/bin/autoconf --force
    configure.ac:23: error: possibly undefined macro: AC_LIBTOOL_WIN32_DLL
    If this token and others are legitimate, please use m4_pattern_allow.
    See the Autoconf documentation.
    configure.ac:37: error: possibly undefined macro: AC_DISABLE_SHARED
    configure.ac:38: error: possibly undefined macro: AC_PROG_LIBTOOL
    configure.ac:39: error: possibly undefined macro: AC_ENABLE_SHARED
    autoreconf: /usr/bin/autoconf failed with exit status: 1
    autogen: autoreconf -i failed.
    make: *** [udis86/libudis86/.libs/libudis86.a] Fehler 1
    me@Ulfuntu:~/Projects/wxHexEditor$ ls -l
    insgesamt 832
    -rw-r--r-- 1 me me 1492 Jan 1 22:52 COMPILE
    drwxr-xr-x 3 me me 4096 Jan 1 22:52 contrib
    drwxr-xr-x 2 me me 4096 Jan 1 22:52 docs
    -rwxr-xr-x 1 me me 241 Jan 1 22:52 GUILocaleFix.sh
    -rw-r--r-- 1 me me 777400 Jan 1 22:52 HexEditorGui.fbp
    drwxr-xr-x 3 me me 4096 Jan 1 22:52 locale
    -rwxr-xr-x 1 me me 5334 Jan 1 22:52 makefile
    drwxr-xr-x 10 me me 4096 Jan 1 22:52 mhash
    drwxr-xr-x 4 me me 4096 Jan 1 22:52 resources
    drwxr-xr-x 3 me me 4096 Jan 1 22:52 src
    -rw-r--r-- 1 me me 6689 Jan 1 22:52 testfile.swp
    -rw-r--r-- 1 me me 2412 Jan 1 22:52 testfile.swp.tags
    drwxr-xr-x 11 me me 4096 Mär 14 16:32 udis86
    -rw-r--r-- 1 me me 8204 Jan 1 22:52 wxHexEditor.cbp
    -rw-r--r-- 1 me me 339 Jan 1 22:52 wxHexEditor.workspace
    me@Ulfuntu:~/Projects/wxHexEditor$

    • sda4 is my extended partition, containing sda5, sda6, sda7, so should be much more than 1024 bytes.
    • "you need a gcc for compile this tool"
      gcc is indeed included in Ubuntu default distribution, but not autotools/automake, so IMHO should be mentioned in compile instructions.

     
    Last edit: CoSoCo 2013-03-14
  • Death Knight®

    Death Knight® - 2013-03-15

    Message says you also need a "libtool" for compiling.

     
  • CoSoCo

    CoSoCo - 2013-03-19

    Thanks!
    (How to know, what "libtoolize" means?)
    Now it seems to work, but where do I find the executable?
    I got this at the end:
    /bin/sh: 1: g++: not found
    make: *** [src/HexEditorGui.o] Fehler 127

     
    Last edit: CoSoCo 2013-03-20
  • CoSoCo

    CoSoCo - 2013-03-20

    OK, I also installed g++
    But now I get:
    ich@Ulfuntu:~/Projects/wxHexEditor$ make OPTFLAGS="-fopenmp"
    msgfmt locale/tr/wxHexEditor.po -o locale/tr/wxHexEditor.mo
    make: msgfmt: Kommando nicht gefunden
    make: *** [locale/tr/wxHexEditor.mo] Fehler 127
    So I searched for msgfmt and found liblocale-msgfmt-perl 0.14-1
    ...installed, but same error again.
    Any idea, what I can do now?

     
  • Death Knight®

    Death Knight® - 2013-03-21

    You need to install gettext for "msgfmt" tool.

     
  • CoSoCo

    CoSoCo - 2013-03-22

    Wow, now I successed and found the executable running, thanks.
    Did you found a solution for the 2 problems?
    - No response after opening block device as non-root user.
    - Only 1024 bytes visible from extended partition.

     
  • Death Knight®

    Death Knight® - 2013-03-22

    About 1024 byte on extended partition:

    triQuad:/ # dd if=/dev/sdc4 of=/sdc4
    2+0 records in
    2+0 records out
    1024 bytes (1,0 kB) copied, 0,00985803 s, 104 kB/s

    This is why of your 1024 byte...
    Linux make it. wxHexEditor just read the /dev/sdx# .
    Nothing more.

    And I don't know why you don't have and response.
    Can you check about if your system has "gnomesu" command?

     
  • CoSoCo

    CoSoCo - 2013-03-26

    This is sad, that Linux limits to 1024 bytes. On Windows I have WinHex, which is able to display the extended partition completely. Maybe you find a workaround some time.
    I don't have gnomesu, it not avalilable for Ubuntu, but here is gksudo.

     
    Last edit: CoSoCo 2013-03-26
  • Death Knight®

    Death Knight® - 2013-03-27

    Well, this is possible by writing some code, but, does it worth to do that?
    Instead of that, you can inspect every partition alone OR you can open whole HDD.

    I think I have better to focus on auto tag regeneration for devices.
    For example, you just open whole HDD as a device and wxHexEditor just add tags for indicating every partition type, start and end positions.

    Might I also could add FAT table indicator later. Who knows?

    About gnomesu vs gksudo... What if you add symbolic link to gksudo as a gnomesu? wxHexEditor just uses gnomesu. Ialso could ask root password using my own dialogs but people can't know if I use this right for good reasons in this time. Gnomesu just let you read command that request the root permission.

    I try to add gksudo support also in next version, for you. ;-)

     
  • CoSoCo

    CoSoCo - 2013-03-28

    Hi again,
    extended partition access is not so important, if there is a auto tag.
    Do you know WinHex? Have a look at as inspiration for pretty good features e.g. smart template manager.

    I've tried with symbolic link, it doesn't work either, so would be good to add gksudo support.

     
    Last edit: CoSoCo 2013-03-28
  • Death Knight®

    Death Knight® - 2013-03-28

    From about page of wxHexEditor:
    "I used WinHex at my past while I am windows boy, but I grown, who uses windows except gaming? WinHex is fantastic, professional program. wxHexEditor will not as good as WinHex. Even you cannot compare them."

    But you look like start comparing them. It's good.
    I want to add some template manager for long time but I don't think if wxHexEditor is ready for this.

    I also add "gksu" and "gksudo" support to svn-trunk.
    Could you please try it and report if it's working? I don't have gksu/gksudo. But I think it's need to work if you have /usr/bin/gksu or /usr/bin/gksudo files...

     
  • CoSoCo

    CoSoCo - 2013-04-05

    Hi, code from svn trunk doesn't build:

    cd mhash; ./configure --host=CFLAGS="-g -O2 -Wall "
    configure: WARNING: If you wanted to set the --build type, don't use --host.
    If a cross compiler is detected then cross compile mode will be used.
    checking build system type... x86_64-unknown-linux-gnu
    checking host system type... config.sub: too many arguments
    Try `config.sub --help' for more information.
    configure: error: /bin/bash ./config.sub CFLAGS=-g -O2 -Wall failed
    make: *** [mhash/lib/.libs/libmhash.a] Fehler 1

     
  • Death Knight®

    Death Knight® - 2013-04-05

    I aware than but I don't find if that is crucial issue. It's just a missing space at make file. Anyway, I fixed that. Check latest revision :)

     
  • CoSoCo

    CoSoCo - 2013-04-06

    There still happens nothing when I try to open a device while running wxHexEditor from user login. This is what I get:
    me@Ulfuntu:~/Projects/wxHexEditor/nightly/wxhexeditor-code$ wxHexEditor

    (wxHexEditor:15998): LIBDBUSMENU-GTK-CRITICAL **: watch_submenu: assertion `GTK_IS_MENU_SHELL(menu)' failed

    (wxHexEditor:15998): LIBDBUSMENU-GTK-CRITICAL **: watch_submenu: assertion `GTK_IS_MENU_SHELL(menu)' failed

    (wxHexEditor:15998): LIBDBUSMENU-GTK-CRITICAL **: watch_submenu: assertion `GTK_IS_MENU_SHELL(menu)' failed

    (wxHexEditor:15998): LIBDBUSMENU-GTK-CRITICAL **: watch_submenu: assertion `GTK_IS_MENU_SHELL(menu)' failed
    Rahman ve Rahim olan Allah'ın adıyla.

    (wxHexEditor:15998): CRITICAL : os_bar_hide: assertion `OS_IS_BAR (bar)' failed

    (wxHexEditor:15998): Gtk-CRITICAL **: IA__gtk_widget_hide: assertion `GTK_IS_WIDGET (widget)' failed

    (wxHexEditor:15998): CRITICAL : os_bar_set_parent: assertion `OS_IS_BAR (bar)' failed

    (wxHexEditor:15998): LIBDBUSMENU-GLIB-WARNING **: Trying to remove a child that doesn't believe we're it's parent.

    (wxHexEditor:15998): LIBDBUSMENU-GLIB-WARNING **: Trying to remove a child that doesn't believe we're it's parent.

    (wxHexEditor:15998): LIBDBUSMENU-GLIB-WARNING **: Trying to remove a child that doesn't believe we're it's parent.

    (wxHexEditor:15998): LIBDBUSMENU-GLIB-WARNING **: Trying to remove a child that doesn't believe we're it's parent.

    (wxHexEditor:15998): LIBDBUSMENU-GLIB-WARNING **: Trying to remove a child that doesn't believe we're it's parent.

    (wxHexEditor:15998): LIBDBUSMENU-GLIB-WARNING **: Trying to remove a child that doesn't believe we're it's parent.

    (wxHexEditor:15998): LIBDBUSMENU-GLIB-WARNING **: Trying to remove a child that doesn't believe we're it's parent.
    me@Ulfuntu:~/Projects/wxHexEditor/nightly/wxhexeditor-code$

     
  • CoSoCo

    CoSoCo - 2013-04-06

    With sudo it works, and I get:
    me@Ulfuntu:~/Projects/wxHexEditor/nightly/wxhexeditor-code$ sudo wxHexEditor

     
    Last edit: Death Knight® 2013-04-08
  • Death Knight®

    Death Knight® - 2013-04-08

    Could you compile with DEBUG?

    make OPTFLAGS="-D_DEBUG_"
    You can see command line of permission change at output while trying to open file.

    Could you also check "src/FAL.cpp Line:169"
    wxString cmd;
    if( wxFile::Exists( wxT("/usr/bin/gnomesu")))
    cmd = wxT("gnomesu -u root-c \"chown ");
    else if( wxFile::Exists( wxT("/usr/bin/gksu")))
    cmd = wxT("gksu -u root \"chown ");
    else if( wxFile::Exists( wxT("/usr/bin/gksudo")))
    cmd = wxT("gksudo -u root \"chown ");
    cmd+=wxGetUserId() + wxT(" ")+ myfilename.GetFullPath() +wxT("\"");
    #ifdef DEBUG
    std::cout << "Changing permission of " << myfilename.GetFullPath().ToAscii() << std::endl;
    std::cout << cmd.ToAscii() << std::endl;
    #endif
    wxShell( cmd );

    Here is the command line for changing ownership of the file.
    if /usr/bin/gnomesu is available, program tries to execute it.
    or other gksudo and gksu.

    This is what I can make without installing ubuntu. I don't know what is the problem. But this intended to work...

     
    Last edit: Death Knight® 2013-04-08
  • Death Knight®

    Death Knight® - 2013-04-08

    I installed ubuntu thru KVM and yes, there are something weird.

    For example I could read files with "root,root" permission without doing any "sudo" with my user login. But normally, I don't have any access, even read access to those files. It's really, really weird.

    The best thing that you can, install codeblocks.
    And put some breakpoints and debug it.
    I cannot since I installed ubuntru 12.10 and it has to work with Compiz, which is really slow on KVM.
    Good lucks.

     
  • CoSoCo

    CoSoCo - 2013-04-08

    With debug compile I get:
    make: There is nothing to do with target "all".

    Code at line 169 is same here.
    I'm wondering about:
    //Changing owner of file...
    //I think it's better than changing permissions directly. Doesn't it?
    //Will restore owner on file close.
    This seems dangerous to me. If wxHexEditor crashes, original ownership will never be restored. :-(
    Maybe check solution at GParted. It can be run from user login, but if there are changes to write to disk, it asks for root password.

    What is wrong about, if root,root owned file is readable? Maybe it has read permission for world, e.g. -rwxrwxr-x

    I have installed codeblocks successfully, will try next days ...hopefully :-)

     
  • Death Knight®

    Death Knight® - 2013-04-08

    You right. but owning file is related with "reading" of disk, not for writing.
    I don't think if user could read the disks at many system without root password. If you look the code, it just try to open file for reading, if not successful, than try to own file. Which is good approach. I can set +r permission for everyone but this time unauthorized persons have read access to file...

    What happen if wxHexEditor crashed and permissions never restored?
    Nothing. Root could read it anyway. Just users temporary permission became permanent. At least until reboot. Which doesn't look like too dangerous.

    I download 12.04, which could disable codeblocks. Will try soon.
    Thanks.

     
  • CoSoCo

    CoSoCo - 2013-04-09

    With codeblocks I was able to build and run the new version. I didn't find out, how to do debug, e.g. setting a breakpoint had no effect.

    Ok, now we have some nice workaround with following caveats:
    - each opening and each closing of a device requires repeated input of password
    - device is no more protected during this time
    - can't write binary changes to the device

    I really need write permission to block device data.
    So please investigate in a solution.

     
  • Death Knight®

    Death Knight® - 2013-04-09
    1. each opening/closing of a device requires repeated input of password. It's normal since wxHexEditor doesn't USE or hide your password. It just ask permission to owning file.

    2. What you mean? Device is protected during that time. You owned file and could corrupt or fix it. Power comes with responsibility. In this time, device or file is protected from other users that doesn't has the right to reach file/device.

    3. Why? Does it have write permission at file? This might a bug. But you can't write file with read only rights even if you own the file, which is normal. And If I remember correctly, block devices and files bigger than 10MB are open in Read-Only mode at wxHexEditor. For make it write-able, you need to change file mode to Writeable from Options menu.

     
  • CoSoCo

    CoSoCo - 2013-04-10
    1. I just wanted to point to the "inconvenience". Maybe you could enhance the dialogue with:
      "File is not readable by permissions.
      You should restart wxHexEditor from <owner> account,
      or do you want to own the file temporarily?"

    2. I think there are good reasons why raw disk access is prohibited for normal user account, e.g. to prevent from malware attacks. Temporary ownership of normal account opens that barrier even temporary or for longer time if wxHexEditor crashes.

    3. Sorry, I didn't know about the optional write access via menu action. Setting it to writeable works, GREAT !

    4. If opening raw partition via ownership trick, the right text pane shows invalid data, see attachment :-(

     
    Last edit: CoSoCo 2013-04-10
  • Death Knight®

    Death Knight® - 2013-04-10

    1 & 2. Restarting wxHexEditor as a root is another alternative. But users need to know that what they are doing. If they want to open disk, that could do it by manually. Indeed, this functionality is "not only" developed for open disk devices but for files that owned by root or other users. Linux users, specially those try to edit their HDD with an hex editor, should need to know that hey could also run wxHexEditor as root. The program offer this just for easy working.

    Also I don't believe that running any program as root does safer than reducing file permission. Because you cannot assume that the program is bug free or free from malware.

    But for your taste, you can change "the line" for reducing file permission with a line like "killall wxHexEditor&; wxHexEditor %filename???" function. It's beauty of open source.

    1. I need good documentation wiki for wxhexeditor.

    2. Could you try to change encoding selection? I believe it's related with it.
      Regards.

     
    Last edit: Death Knight® 2013-04-10
  • CoSoCo

    CoSoCo - 2013-04-11

    Yes, but there are also beginners. I think, it doesn't hurt, to give them a little hint at the appropriate place.

    If you change the owner of a file/device, it becomes open for any process e.g. a browser plugin, containing an unknown security hole. But if only you assign the required privileges to one process, here wxHexEditor, only this single process is allowed to access the precarious file/device. The latter seems more secure to me.

    Yes, if I change encoding to ASCII, the right text pane shows valid data.
    If I run wxHE with sudo, the encoding is correct from the beginning. ..But the options dialogue doesn't provide the possibility, to change the encoding :-(

     
    Last edit: CoSoCo 2013-04-11
  • Death Knight®

    Death Knight® - 2013-04-13
    1. Do not think this for just devices but read-only files that belongs to root or someone other. So this create issues more than it solves.

    2. In linux, I think the common way is reducing permissions of file, not elevate program permissions to root. And people couldn't trust the program that doesn't come with OS. This is 3rd party program and it could include a backdoor to your system. Or such a code could be injected somehow from someone. In short, it's not good to trust it. I don't think if anyone inspects even the original the code well. Users are in safe if they don't alter their boot drives this way. But they are not in safe anymore if they just trying to change their USB flash disk by using wxHexEditor with sudo.

    3. Himm. It's might probably due "sudo wxHexEditor" command. It might change the permissions of the ~/.wxHexEditor file where the configurations are stored at "your" home directory. In OpenSuSE, I tried with gnomesu and there are no issues because "gnomesu wxHexEditor" just write that configuration file to /root/.wxHexEditor instead of my home directory and don't have such issue. Please try to check ~/.wxHexEditor permissions to diagnose issue.
      THanks

     
  • CoSoCo

    CoSoCo - 2013-04-14

    ~/.wxHexEditor permissions: root:root -rw-rw-r--
    /root/.wxHexEditor: not existing
    After I deleted ~/.wxHexEditor and run wxHexEditor from me:
    ~/.wxHexEditor permissions: me:me -rw-rw-r--
    After sudo wxHexEditor from me, again:
    ~/.wxHexEditor permissions: root:root -rw-rw-r--

     
  • Death Knight®

    Death Knight® - 2013-04-14

    Yes, as I guessed.
    This is another why that for avoid running wxHexEditor with sudo.
    Because AFAIK it run program with your username and root rights...
    Instead, you can try with "gksu". It might help you.

     
  • CoSoCo

    CoSoCo - 2013-04-15

    With gksu wxHexEditor now /root/.wxHexEditor was created :-)
    But I still see wrong chars in the text view column :-(

    Maybe you could avoid the unwanted change of ~/.wxHexEditor ownership, caused by sudo wxHexEditor, if you wouldn't delete the file before writing new data into it.
    E.g. if I run "sudo nautilus", ownership of ~/.gconf/apps/nautilus/preferences/%gconf.xml doesn't change to root, so there seems to be another solution, to run an application with my username but root rights, without corrupting the settings file.

    Conclusion:
    It now took 2 weeks, to find out how to correctly open block devices with wxHexEditor, so I still again think, there should be some more detailed info in the message box, when user tries to open root owned file with user privileges.

     
    Last edit: CoSoCo 2013-04-15
  • Death Knight®

    Death Knight® - 2013-04-17

    *I believe wrong chars issue is cleared with latest trunks. Are you sure?

    *sudo wxHexEditor is already a bad command. You couldn't use sudo for graphical programs at linux. Yes some of programs are working with it like gparted. But I don't think if it's worth to do make a research on it. I want to spend my time on other required features instead of "sudo" which users could find a workaround...

    *It tooks 2 weeks because I didn't aware that if gnomesu doesn't available on some linux distro. Also I forget to add error message to that function if there is no gnomesu. Thanks for indicating that.

    If I add a message like "You could try run wxHexEditor as a root with gnomesu", it looks like that I am trying to teach people how to use their linux. If user is rookie, it's better to not open his/her hdd with wxHexEditor. If user isn't a rookie, than he/she find my message silly.

    At the end of the day, I am satisfied about wxHexEditor device opening capabilities at all.

     
  • CoSoCo

    CoSoCo - 2013-04-18

    I have svn updated from trunk.
    The wrong chars issue is cleared now with latest trunks :-)

    Note: GParted never needs to run with sudo, gksu or gmomesu.
    If it's running with user privileges, and you hit "perform action", it asks - only once - for root password, without changing the files owner.

    In FAL.cpp I see for WXMSW:
    "File is not readable by permissions."
    "Please change file permissions or run this program with root privileges"
    (BTW, the closing period is missing)
    but for WXGTK:
    "File is not readable by permissions."
    "Do you want to own the file?"

    I more would like for WXGTK:
    "File is not readable by permissions."
    "Please run this program with root privileges or change file permissions."
    "Do you want to own the file temporarily?"

    Additionally I have proposed your product to include in Parted Magic.

     
    Last edit: CoSoCo 2013-04-18
  • Death Knight®

    Death Knight® - 2014-04-02

    I forget this threat.
    Summoning after a year.

    Well, at windows, there is no way that I know to reach disk devices or files with some different permissions with standard user interface. But at linux I can. Also I am not like running wxHexEditor code as a root. It could be dangerous.

    But added required changes to latest trunk. So at wxGTK it's also asks like:
    "Please change file permissions or run this program with root privileges"
    Thanks.

     

Log in to post a comment.

Get latest updates about Open Source Projects, Conferences and News.

Sign up for the SourceForge newsletter:

JavaScript is required for this form.





No, thanks