Hi Eric,

Thanks for the progress update.  Your remark about 2.6 only raises a question for me: What's the deal on wxhaskell and ghci-friendliness?  Do we still have to use wxWindows/wxWidgets 2.4.2 in order to run more than one GUI per ghci session?  Will it be possible at all any more?

  - Conal

On Feb 16, 2008 5:24 AM, Eric Y. Kow <eric.kow@gmail.com> wrote:
Hi everyone,

I have uploaded an unofficial pre-release of wxhaskell on hackage.  It is
available as two packages, wxcore and wx.


Let me stress that this is only experimental; it is NOT an official release.

I think this works under Linux and MacOS X, but not under Windows.

It seems to work best under MacOS X (10.4 on Intel).  If you have any trouble,
you are likely going to have to install wxcore by hand (passing in configure
flags, etc) and then install wx automatically:

 cabal install wx

General notes
This only works with wxWidgets 2.6.

Windows and maybe MacOS X
The wxcore cabal script is merely a wrapper around the makefile and the
configure script.  So you'll still need to have make and the ability to run
shell scripts.  As shelarcy pointed out, this probably does not work for
Windows, and you'll have to go the old-fashioned route (using the darcs
repository as well).

The configure options that worked for me (wxWidgets) are
 ./configure --enable-display --enable-unicode --with-opengl --with-mac --without-odbc --enable-mediactrl --disable-monolithic

Note that I also had to do
 sudo mkdir -p /usr/local/wxhaskell/bin
 sudo ln -s /usr/local/bin/wx-config /usr/local/wxhaskell/bin

This makes the wxcore package use your version of wxWidgets and not the one that came with the

On Linux, I had to supply --with-opengl to the configure script:

 runhaskell Setup --configure-opt=--with-opengl

I noticed also that on Ubuntu Gutsy Gibbon, I had some trouble
running sample applications with wxGTK 2.8, so I aptitude installed
libwxgtk2.6-dev and specified to wxhaskell to use it instead of the
newer version:

 mkdir -p /usr/local/wxhaskell/bin
 ln -s /usr/lib/wx/config/gtk2-unicode-release-2.6 /usr/local/wxhaskell/bin/wx-config
 runhaskell Setup --configure-opt=--with-opengl

Where to next?
I hope that this makes life a little easier, and that the being
on hackage either attracts more users/contributors to wxhaskell.

Here are some key questions we need to answer for 0.10.3:
* Can we make it possible to run wxhaskell programs under Linux
 without the --with-opengl flag? Seems to be fine under MacOS X.

* Why are people having build trouble lately?
 * You have to obliterate a patch for wxhaskell on PowerPC, why?
 * What about the issue that Malcolm pointed out with not linking to
  the -gl version of wxWidgets [odd; doesn't wx-config tell the right thing?]
 * What about Gwern's too many symbolic links problem?

* Why doesn't wxhaskell work with wxGTK 2.8?  I thought we had
 worked out some compatibility fixes?

* What do we need for Windows users to be able to cabal install wx?

... and many more.  Please help!

Eric Kow <http://www.nltg.brighton.ac.uk/home/Eric.Kow>
PGP Key ID: 08AC04F9

Eric Kow <http://www.nltg.brighton.ac.uk/home/Eric.Kow>
PGP Key ID: 08AC04F9

This SF.net email is sponsored by: Microsoft
Defy all challenges. Microsoft(R) Visual Studio 2008.
wxhaskell-users mailing list