oops -- premature send.

any advice?  what configure options do you use for wxWidgets-2.6.3?

Thanks,   - Conal

On 12/4/06, Conal Elliott <conal@conal.net> wrote:
Thanks for the tips, Eric.  I've built & installed wxWidgets 2.6.3 (configuring with --with-msw --disable-shared --with-opengl --enable-unicode).  When I compile wxHaskell (configuring with --prefix=/usr/local --with-opengl), I get a host of errors, such as

C:/cygwin/usr/local/include/wx/chkconf.h:100:9: #error "wxUSE_PROLOGIO must be defined."
C:/cygwin/usr/local/include/wx/chkconf.h:488:9: #error "wxUSE_NEW_GRID must be defined."
C:/cygwin/usr/local/include/wx/chkconf.h:1184:9: #error "wxUSE_DYNAMIC_CLASSES must be defined as 1"


C:/cygwin/usr/local/include/wx/object.h:438: `wxClassInfo' was not declared in this scope
C:/cygwin/usr/local/include/wx/object.h:438: `info' was not declared in this  scope
C:/cygwin/usr/local/include/wx/object.h:438: invalid data member initialization

On 12/2/06, Eric Y. Kow <eric.kow@gmail.com> wrote:
On Thu, Nov 30, 2006 at 14:26:43 -0800, Conal Elliott wrote:
> I don't know whether Unicode was enabled in my wxWidgets build.  I have
> wxWidgets 2.4.2 and configured compilation without any mention of unicode.
> Would I want unicode enabled or disabled?

You want it enabled

> I just tried a clean build & install with --enable-unicode and one with
> --disable-unicode, and I got the same truncation behavior in both cases.

You might also want to make sure that wxhaskell is using the wxWidgets
you think it's using.  You can set this explicitly with ./configure

> What is the ideal version of wxWidgets and what are the ideal build
> configuration parameters for wxWidgets & wxHaskell with ghc-6.6?

> And does anyone have wxHaskell working correctly (not just compiling) with
> ghc-6.6?

It has worked for me in the past with 2.4.2 and ghc-6.4.1, and it seems
to be working for me with ghc-6.6 and wxWidgets 2.6.3

Eric Kow                     http://www.loria.fr/~kow
PGP Key ID: 08AC04F9         Merci de corriger mon franšais.