I think I fixed the problem. In wxc/src/cpp/eljpen.cpp line 159 I changed:

    * _ref = NULL;


    _ref = NULL;

After that wxHaskell compiled just fine. I tried a test-program and that also worked just fine.

Kind regards,

Mads Lindstrøm

2012/12/2 Mads Lindstrøm <mads.lindstroem@gmail.com>

I am trying to install wxHaskell on Debian Wheezy.

First, I installed wxWidgets 2.9.4:

./configure --enable-mediactrl
make install


cabal install wx

Which results in the following failure:

/usr/bin/gcc -Wl,--hash-size=31 -Wl,--reduce-memory-overheads -Isrc/include -I/usr/local/include/wx-2.9 -I/usr/local/lib/wx/include/gtk3-unicode-2.9 -D__WXGTK__ -DWXUSINGDLL -D_FILE_OFFSET_BITS=64 -DwxcREFUSE_MEDIACTRL -fPIC -c src/cpp/eljpen.cpp -o dist/build/src/cpp/eljpen.o
src/cpp/eljpen.cpp: In function ‘void wxPen_GetStipple(void*, wxBitmap*)’:
src/cpp/eljpen.cpp:159:13: error: conversion from ‘long int’ to ‘const wxBitmap’ is ambiguous
src/cpp/eljpen.cpp:159:13: note: candidates are:
In file included from /usr/local/include/wx-2.9/wx/bitmap.h:251:0,
                 from /usr/local/include/wx-2.9/wx/generic/panelg.h:15,
                 from /usr/local/include/wx-2.9/wx/panel.h:70,
                 from /usr/local/include/wx-2.9/wx/wx.h:41,
                 from src/include/wrapper.h:20,
                 from src/cpp/eljpen.cpp:1:
/usr/local/include/wx-2.9/wx/gtk/bitmap.h:83:5: note: wxBitmap::wxBitmap(GdkPixbuf*)
/usr/local/include/wx-2.9/wx/gtk/bitmap.h:73:5: note: wxBitmap::wxBitmap(const char* const*)
/usr/local/include/wx-2.9/wx/gtk/bitmap.h:64:24: error:   initializing argument 1 of ‘wxBitmap& wxBitmap::operator=(const wxBitmap&)’
cabal: Error: some packages failed to install:
wx- depends on wxc- which failed to install.
wxc- failed during the building phase. The exception was:
ExitFailure 1
wxcore- depends on wxc- which failed to install.

Any suggestions to how I can fix this?


Mads Lindstrøm