On 21 September 2011 16:30, David Virebayre <dav.vire+haskell@gmail.com> wrote:
Bonjour,

> Ah! Yes! I had error too, but I can't remember how I resolved it, which
> makes me think I might have just cleaned everything up and started afresh
> (just with the modified library list);  have you tried that?

I'm not sure I did this right, but I deleted my wxhaskell directory,
issued a darcs get, changed wxcore/Setup.hs again, and re-tried
cabal-dev

Same result.

the darcs get was suspiciouly fast.

David

Aha, I did do something to fix this!
Here's my 'probably breaks other things but hasn't caused me a problem as of yet' fix:
(I really need to start getting all my local patches reviewed and pushed to code.haskell.org..)

[wxEventType is an extern type in wxWidgets 2.9.2
dukedave@gmail.com**20110729050251
 Ignore-this: a709f60a95638a6ae87b570dc7d1072d
 Compare wxEventType in include/wx/event.h in wxWidgets 2.8.10 and 2.9.2,
 you will see that the latter contains the lines:
     extern WXDLLIMPEXP_BASE const wxEventType wxEVT_NULL;
     extern WXDLLIMPEXP_BASE const wxEventType wxEVT_FIRST;
 This was causing a "Conflicting exports" error as detailed here:
 http://sourceforge.net/mailarchive/message.php?msg_id=27810904
 Because wxc_glue.h previously exported these as ints.
] hunk ./wxcore/src/include/wxc_glue.h 18
-int expEVT_NULL();^M$
-int expEVT_FIRST();^M$