On 23 Apr 2012, at 23:47, Eric Kow wrote:

I'm a bit confused by this. Isn't /opt/local used by Macports rather than Homebrew?
also, does non-ghci stuff work?

Apologies - it was MacPorts  - I was getting hopelessly confused at this stage ..

If I try to compile HelloWorld.hs I get the error below

It seems clear that I need to identify and inform the build process about my architecture

However there are no clear instructions on the wiki on how to do this

(PS - I am having equal  difficulties build wxH 0.9 on wxW 2.9.3  on 64bit windows.... - but that's for another email)


$ ghc --make -package wx HelloWorld.hs 
[2 of 2] Compiling Main             ( HelloWorld.hs, HelloWorld.o )
Linking HelloWorld ...
ld: warning: in /opt/local/lib/libwx_osx_cocoau_xrc-2.9.dylib, file was built for unsupported file format which is not the architecture being linked (i386)
ld: warning: in /opt/local/lib/libwx_osx_cocoau_webview-2.9.dylib, file was built for unsupported file format which is not the architecture being linked (i386)
ld: warning: in /opt/local/lib/libwx_osx_cocoau_stc-2.9.dylib, file was built for unsupported file format which is not the architecture being linked (i386)
ld: warning: in /opt/local/lib/libwx_osx_cocoau_richtext-2.9.dylib, file was built for unsupported file format which is not the architecture being linked (i386)
ld: warning: in /opt/local/lib/libwx_osx_cocoau_ribbon-2.9.dylib, file was built for unsupported file format which is not the architecture being linked (i386)
ld: warning: in /opt/local/lib/libwx_osx_cocoau_propgrid-2.9.dylib, file was built for unsupported file format which is not the architecture being linked (i386)
ld: warning: in /opt/local/lib/libwx_osx_cocoau_aui-2.9.dylib, file was built for unsupported file format which is not the architecture being linked (i386)
ld: warning: in /opt/local/lib/libwx_osx_cocoau_gl-2.9.dylib, file was built for unsupported file format which is not the architecture being linked (i386)
ld: warning: in /opt/local/lib/libwx_osx_cocoau_html-2.9.dylib, file was built for unsupported file format which is not the architecture being linked (i386)
ld: warning: in /opt/local/lib/libwx_osx_cocoau_qa-2.9.dylib, file was built for unsupported file format which is not the architecture being linked (i386)
ld: warning: in /opt/local/lib/libwx_osx_cocoau_adv-2.9.dylib, file was built for unsupported file format which is not the architecture being linked (i386)
ld: warning: in /opt/local/lib/libwx_osx_cocoau_core-2.9.dylib, file was built for unsupported file format which is not the architecture being linked (i386)
ld: warning: in /opt/local/lib/libwx_baseu_xml-2.9.dylib, file was built for unsupported file format which is not the architecture being linked (i386)
ld: warning: in /opt/local/lib/libwx_baseu_net-2.9.dylib, file was built for unsupported file format which is not the architecture being linked (i386)
ld: warning: in /opt/local/lib/libwx_baseu-2.9.dylib, file was built for unsupported file format which is not the architecture being linked (i386)
ld: warning: in /opt/local/lib/libiconv.dylib, file was built for unsupported file format which is not the architecture being linked (i386)
Undefined symbols:
  "_iconv_open", referenced from:
      _hs_iconv_open in libHSbase-4.3.1.0.a(iconv.o)
     (maybe you meant: _hs_iconv_open)
  "_locale_charset", referenced from:
      _localeEncoding in libHSbase-4.3.1.0.a(PrelIOUtils.o)
  "_iconv", referenced from:
      _hs_iconv in libHSbase-4.3.1.0.a(iconv.o)
     (maybe you meant: _hs_iconv_open, _hs_iconv , _hs_iconv_close )
  "_iconv_close", referenced from:
      _hs_iconv_close in libHSbase-4.3.1.0.a(iconv.o)
     (maybe you meant: _hs_iconv_close)
ld: symbol(s) not found
collect2: ld returned 1 exit status

[~/Documents/wxOnMacOSX]



On Monday, 23 April 2012, Andrew Butterfield wrote:
I've done yet another attempt at installing wxHaskell on Mac OS X (Intel, Snow Leopard)
following the page at 


I setup ghc 7.0.4
I did brew install wxmac --devel

I am then asked to check my path to make sure I am using  "my" wxWidgets and not the default one

(I had deleted an old reference to wx 2.8 - now my path does not mention wxwidgets at all)

wx2.9.3 was installed by homebrew in /opt/local/.... but I had no idea what to put in my path
(A question to stackoverflow got a completely useless answer....)

So I decided to soldier on...
  I did   cabal install wx cabal-macosx   --- waited - all installed just fine - it seemed
to have picked up all the stuff installed by brew.

I then got the EnableGUI module as described lower down the page
it compiled fine
I then edited HelloWord.hs to import it
,and then started ghci as recommended


--
Eric Kow <http://erickow.com>
PGP Key ID: 08AC04F9
------------------------------------------------------------------------------
For Developers, A Lot Can Happen In A Second.
Boundary is the first to Know...and Tell You.
Monitor Your Applications in Ultra-Fine Resolution. Try it FREE!
http://p.sf.net/sfu/Boundary-d2dvs2
_______________________________________________
wxhaskell-users mailing list
wxhaskell-users@lists.sourceforge.net
https://lists.sourceforge.net/lists/listinfo/wxhaskell-users

--------------------------------------------------------------------
Andrew Butterfield     Tel: +353-1-896-2517     Fax: +353-1-677-2204
Lero@TCD, Head of Foundations & Methods Research Group
Director of Teaching and Learning - Undergraduate,
School of Computer Science and Statistics,
Room G.39, O'Reilly Institute, Trinity College, University of Dublin
                          http://www.scss.tcd.ie/Andrew.Butterfield/
--------------------------------------------------------------------