I have Haskell Platform installed, and I recently decided to try out wxHaskell. At first I went here: http://hackage.haskell.org/package/wx (Hackage) and just downloaded the wx- file. I unzipped that and wasn't sure what to do with it, so I went to the #haskell irc channel. They told me about cabal, so I deleted the files that I'd downloaded and tried the following command:

cabal install wx

This appeared to be working, but at the very end I got the following error:

cabal: Error: some packages failed to install:
wx- depends on wxcore- which failed to install.
wxcore- failed during the configuration step. The exception was:
ExitFailure 1

A few lines above that:

setup.exe: wx-config: does not exist.

I was told to go to this page: http://sites.google.com/site/wxconfig/ and download wx-config. I did so, and added the folder that I saved it to to my Path variable. I also created both user and system environment variables called WXWIN and set their value to the full path of wx-config (I tried this with and without the .exe suffix).

Still, cabal continues to claim that wx-config does not exist.

I was hoping that there might be someone on this list who has used wx on Windows and might be able to help me.

Thanks for taking the time to read this,

Jesse Hester