Hi. i have downloaded wxhaskell-bin-msw2.4.2-ghc6.4-0.9.4-1.zip
There wrote ->
"Unzip the release somewhere and click on the newly created
wxhaskell-0.9.4\bin\wxhaskell-register.bat program to
register the wxHaskell package. To uninstall,
you can click on wxhaskell-0.9.4\bin\wxhaskell-unregister.bat
and than remove the wxhaskell-0.9.4 directory."

I did like this but a got this error message ->
ghc-pkg: dependency lang doesn't exist (use --force to override)
Reading package info from "C:\\haskell\\wxhaskell 2.4.2\\bin\\wx.pkg" ... done.
ghc-pkg: dependency wxcore-0.9.4 doesn't exist (use --force to override)
error:
  Unable to register the package using "ghc-pkg".
  Maybe you have an incompatible version of ghc installed?

I have installed Visual Haskell 0.2, and add  "visual haskell\bin" to path enviroment.

may be i something missed...