make rebuild crashes

  • CFS

    CFS - 2007-09-20

    Hello Folks,
    when I try to build the lib's for rebuild i get the following error message:

    >C:\wxd>make rebuild
    >cd wxc
    >make build
    >dmc -D__DMD__ -mn -g -o+none -D__WXMSW__ -D__WXDEBUG__ -Ic:\wxWidgets-2.6.4\incl
    >ude  -Ic:\wxWidgets-2.6.4\lib\dmc_lib\mswd -w- -I. -WA -DNOPCH -HP90 -Ar -Ae
    >-c -owx-config-win.obj wx-config-win.cpp
    >nbytes = 122760, ph_maxsize = 65520
    >Internal error: ph 1848
    >--- errorlevel 1
    >--- errorlevel 1
    >--- errorlevel 1

    Get the same error with different wx versions (2.6.4 / 2.8.5 both working correctly) and with different wxd versions (0.10, 0.11, and the newest cvs version\).

    the wx samples in c++ are building correct with dmc.
    the wxd sample 'hello' is working when I compile everything with make and dmd.

    It would be gread if anybody could help me


    my OS is XP pro SP2
    dmd version: Digital Mars D Compiler v1.020
    dmc version: Digital Mars Compiler Version 8.42n
    rebuild version: ReBuild version 0.67 (based on DMD 1.013)

    • Anders F Björklund

      I never quite could get wx-config working with DMC... Even if I dropped in a ready wx-config.exe because that DMC crashed compiling it, it didn't seem to find the necessary files anyway ?

      So I just went with the regular shell in MinGW and GCC, and it worked without any problems. If you do want to give it a try to get DMC/DMD working, the exe is at

      • CFS

        CFS - 2007-09-20

        I'm not quite shure you got what i meant.
        DMD/DMC is actually working with the default options, but building the lib's for the tool rebuild ( isn't working, so i was wondering if something special, for example: NOT the stlport stl lib i used, is needed?

        • Anders F Björklund

          Maybe it was me that was unclear. I meant that if "wx-config.exe" isn't building for you, then you can download a pre-compiled binary of it and comment it out in the Makefiles to get past this...

    • CFS

      CFS - 2007-09-22

      ok I downloaded "wx-config.exe", removed the dependencies for it in the /wxd/wxc/makefile and added the needed environment parameters(WXDIR + WXCFG) for it recopiled it and see there bingo next error:

      dmc  wx-libs.obj @wx-libs.mak wx-libs.exe
      Command line error: no input file specified--- errorlevel 1

      so my first question is has anybody EVER made it to build the bud/rebuild libraries or is this just a farce to get users away from wxd.

      • Anders F Björklund

        AFAIK, it is yet untested on Windows commandline with DMC... I have only tested it with bash/GDC.

        I normally test the regular Makefile with DM Make and DMC/DMD before release, but that's about it.

    • Tim Keating

      Tim Keating - 2007-10-09

      I haven't made it work yet but I did spend some time on it last week (note: I just realized you're talking about using Rebuild, below I'm talking about using DSSS. They're similar tho, so some of this might help you.) Here's the list of issues I've encountered and how I worked through them.

      1. make.exe on windows doesn't like the -C argument. Remove this from lines 5-7 in dsss.conf.
      2. The build first cleans (always! GAH!), which removes the config.mak file, and then tries to run subordinate make commands that depend on that file. We need to build wxc first.
      3. There's no wxc target in the makefile. I *assume* this is supposed to descend into the wxc dir and do a "make," just as if you built the default target in the makefile in the main wxd dir. So add a target that does this:

              cd wxc
              cd ..

      4. And yet, this doesn't work because of this bug in the makefile in wxc: change line 224 (or thereabouts) to:

          +wx-release.exe -v >>$@

      5. Now I'm getting a problem with dmc not being able to find typeinfo.h. Looking at the command line it spews out, it's clearly not looking in my dmd include directory (FYI: using the DSSS-installed flavor of dmd/dmc here.) Checking the sc.ini reveals that it's using the one from, not from, which adds a whole lot more paths. Download and copy that sc.ini into your dmd bin directory.

      6. Now the build of wxc fails with something that looks like this:

      local_events.h(49) : Error:  storage class is illegal in this context
          { \     ^

      This is caused by stupid TortoiseCVS saving all my files with UNIX line endings. I don't remember this being a problem in the past . . . I switch local_events.h to DOS line endings & off we go. (Incidentally, it's any file with a macro -- the screwy line endings break the macro, so look for #DEFINEs. object.cpp has one, as well.)

      7. AAARGH, then it cleans it again! I don't know why it's firing target "make clean" at this point. Still digging on that.



Log in to post a comment.