Errors compiling wv1.0.3

  • fimi

    fimi - 2005-09-01

    Hi here, i'm trying to compile wv and i'm getting this strange error, that i do not know how to fix, i've tried everything i could, i did alot of research and still no solution for me. I have libiconv installed and i'm running fc3. I have installed it before but now i get this error when i  do make, configure goes fine but the make hangs up. Can someone please tell me what i might be doing worng or what should i be doing?

    thank you in advance....

    here is some debugging data of the error:
    (cd .libs && rm -f && ln -s ../
    if gcc -DHAVE_CONFIG_H -DVERSION=\"1.0.3\" -DXMLCONFIG=\"/usr/local/share/wv/wvConfig.xml\" -DHTMLCONFIG=\"/usr/local/share/wv/wvHtml.xml\" -DWVDATADIR=\"/usr/local/share/wv\" -I. -I. -I. -I. -I. -I. -I./magick -I./libole2 -I./glib-wv -I./expat/xmlparse    -g -O2 -ansi -MT wvSummary.o -MD -MP -MF ".deps/wvSummary.Tpo" -c -o wvSummary.o wvSummary.c; \ then mv -f ".deps/wvSummary.Tpo" ".deps/wvSummary.Po"; else rm -f ".deps/wvSummary.Tpo"; exit 1; fi
    /bin/sh ./libtool --mode=link --tag=CC gcc  -g -O2 -ansi   -o wvSummary  wvSummary.o
    gcc -g -O2 -ansi -o .libs/wvSummary wvSummary.o  ./.libs/ -lz -lm
    ./.libs/ undefined reference to `libiconv_open'
    ./.libs/ undefined reference to `libiconv_close'
    ./.libs/ undefined reference to `libiconv'
    collect2: ld returned 1 exit status
    make[2]: *** [wvSummary] Error 1
    make[2]: Leaving directory `/root/wv-1.0.3'
    make[1]: *** [all-recursive] Error 1
    make[1]: Leaving directory `/root/wv-1.0.3'
    make: *** [all] Error 2

    • Francis James Franklin

      It's a while since I ran into this problem. For some reason wv isn't aware that you are using libiconv. It needs to add -liconv to the link line. See if configure has a --with-libiconv option, or maybe try:
      ./configure LIBS="-liconv"


Get latest updates about Open Source Projects, Conferences and News.

Sign up for the SourceForge newsletter:

No, thanks