Solaris, libwmf, and png.h?

Help
Russ LeBar
2004-04-02
2004-07-11
  • Russ LeBar

    Russ LeBar - 2004-04-02

    I'm trying to use the one on SUN's Software Companion CD. It app.ears to be version 1.0.10,REV=2001.11.28.11.45. The png.h header file is in /opt/sfw/include.

    All of the below fail with the same error message -- configure: error: * * * unable to find "png.h" which is required by libwmf * * *

    configure
    configure --includedir=/opt/sfw/include
    configure --oldincludedir=/opt/sfw/include

    What am I missing? Do I need a newer png.h? The documentation doesn't indicate a specific version and shouldn't the error message from configure be different if I do need a newer version?

    Thanks in advance!

     
    • Russ LeBar

      Russ LeBar - 2004-04-03

      Figured it out:

      ./configure --with-png=/opt/sfw

      After digging through the code, it seems clear that --includedir is meaningless (at least for png.h) and the help for --with-png erroneously implies that you would specify the directory the library is in (/opt/sfw/lib) instead of the parent. And of course this also means the script is assuming the include dir and the lib dir are under the same parent dir.

      Now to see if it will compile... :-)

       
    • scallop

      scallop - 2004-07-11

      i downloaded libwmf version 0.2.8.3 and tried compiling it. The same problem occurred to me:
      configure: error: * * * unable to find "png.h" which is required by libwmf * * *

      i tried:
      ./configure --with-png=/sw/include/

      but the error still persists. Does anyone have a clue what I've done wrong? My png.h file is in /sw/include

      Help is greatly appreciated.

       
    • scallop

      scallop - 2004-07-11

      Oh i got it :-) I tried:

      ./configure --with-png=/sw/

      and it compiled without problem.

      :-) Ta!

       

Get latest updates about Open Source Projects, Conferences and News.

Sign up for the SourceForge newsletter:





No, thanks