Menu ▾ ▴

#75 Service restarts endlessly if log access denied

open
nobody
None
5
2012-12-11
2004-12-30
m.hilpert
No

I installed my application as a Service and changed the
logon user for the service to a domain user with tight
security restrictions. The service didn't start and just
showed this error after a while:

Error 1053: The Service did not respond to the start or
control request in a timely fashion.

the wrapper log didn't change, so nothing was written to
it. Unfortunately, the Windows eventlog didn't tell this
and it took me some time to find the solution: I had to
give the wrapper.log file write access right for this user.

=> the wrapper should check this and right a readable
error message to the event viewer.

After that change, the service still didn't start but
restarted endlessly. At least, the wrapper now writes to
the wrapper.log and showed an application error that
the initialization had an IOException because access to
the application log file failed. Because the application
retried to gain access to the log file (because it is on a
network drive and network errors can occur
occasionally), the initialization never returns. This had
the strange effect, the the wrapper logged that it tried
5 times to start the application - but it never stops! It
tries to start the service again and again ...

=> the wrapper should stop restarting when it failed
after these 5 times. (Or is there a reason it shouldn't?)

Discussion


Log in to post a comment.