Error Socket for Data Connection

Help
Karmit
2011-03-05
2012-12-10
  • Karmit

    Karmit - 2011-03-05

    I installed successfully on 3 PC ( 1 using 32bit XP, 2 using 64 bit W7 ) and they all show the same error during send FAX : Error Socket for Data Connection

    I do not change anything on the server and another client works on the 32bit XP.

    Thanks !!

    Karmit

     
  • Michal Havranek

    Michal Havranek - 2011-03-05

    I think you have firewall restriction on HylaFAX server for passive FTP connection ports.
    If no, try check "Ignore PASV IP" on settings port dialog.

    Michal

     
  • Karmit

    Karmit - 2011-03-10

    Dear Michal,

    "Ignore PASV IP" does not work. I have open TCP 4559 on server, is that okay ?

    Karmit

     
  • Michal Havranek

    Michal Havranek - 2011-03-10

    Hello
    No. Range for passive ports is 1024-65535. This ports have to be open on firewall for incomming connection on hylafax server and for outgoing connection on your PC.

    If you are on the same LAN or you are behind a router and you can use port forwarding then is possible using active connection and define exactly port number for data transfer to your PC.

    If you capable open ports for passive connection on hylafax server then it will be OK.

    Or you want to use active connection? Then it is possible add this feature to program but it takes some time.

    Michal

     
  • Karmit

    Karmit - 2011-03-16

    Michal,

    All PC should be on the same LAN and behind a router provided by ISP. Do you mean I need to open ports 1024-65535 ? I am using CentOS 5.5 and just know a bit about the firewall setting. What is the different between passive and active connection ? I just don't want to open so many ports 1024-65535 on the firewall.

    I will try to disable the firewall on the Server for a test. But, it had been working fine before …

    Thank you very much for your help.

    Karmit

     
  • Michal Havranek

    Michal Havranek - 2011-03-16

    Hello
    - different between passive and active FTP connection
    Please use to Google. Simple it is connect method.

    - I just don't want to open so many ports 1024-65535 on the firewall.
    OK, but Hylafax gives no way to limit the passive port range.

    - But, it had been working fine before
    Did you use other clients before?

    Please try to disable firewall and we will see.

    Active connection requires only port 4559 on server and one port on your PC for incoming connection from server. But it depends if you have public IP or if you can forwarded incoming port.
    Are you able active connection to server? If yes then no problem :-)  I will send new version of program where it will be possible.

    Michal

     
  • Karmit

    Karmit - 2011-03-22

    Dear Michal,

    Pyla, another client is still working. But I have problem with phone book. I have been working with two clients in Java. I will tell you the result after testing with fire-wall off. Looking forward for your new version as I need to install it and let other users in the office use HylaFax more easily.

    You are great ! Thank you !!!

    Karmit

     
  • Michal Havranek

    Michal Havranek - 2011-03-22

    Version 1.0.0.6 can use active connection. Check "use active connection" on settings dialog.  Then you have to open the incoming port on your PC for incoming connection. Firewall on HylaFax can be on.
    Before install new version uninstall the older first.

    Michal

     

Log in to post a comment.

Get latest updates about Open Source Projects, Conferences and News.

Sign up for the SourceForge newsletter:

JavaScript is required for this form.





No, thanks