mp4a wmp11 xp large library - won't add woes

  • Zoltan

    Zoltan - 2007-06-06

    after hours of wasted time and ALL scams tried, I conclude there is a real problem with adding mp4a files to wmp11 even with wmptagsupportextender 1.4
    . I have 78000 files approx in the ratio 3:1 in favour of mp3. Approx the first 200 mp4a are added then successive attempts to add the others fail and crash wmp11. restart and wmp11 disables the plugin. I've scanned the mp4a for errors that might stall and found nothing. deleted the wmp11 library several times and reinstalled all of it. I must conclude there is a bug in wmp tagsuppor extender that doesn't like large libraries. I'm running xp sp2 latest everything.

    cheers, Z

    • elsevers

      elsevers - 2007-06-07

      I have the same problem! I described it a couple posts back. Has anyone figured out a solution to this?


    • Zoltan

      Zoltan - 2007-06-08

      I sounded a bit ungrateful in my first post. I think MPTSE is a great project and would be incredibly useful if I could make it work. Please don't give up the development because of moaners like me! There are so many Ipod + mp3 users out there who don't want two separate libraries to manage. I'll keep looking...

    • M@B

      M@B - 2007-06-12

      Ok then, let's find it

      What do you mean by 'adding'...?
      Are you drag and dropping those file in the library ?
      Scanning it with the "Add Folder" button ?
      Waiting for it to appear in the library by monitoring the folder ?

      Which program do you use to rip these mp4...iTune (i suppose), any other ?


    • elsevers

      elsevers - 2007-06-20

      So here is a little more detail with my situation and what I have noticed:

      I am running Windows Media Center Edition 2005 with Windows Media Player 11 and would like to play mp4's (or rather m4a's) that I ripped with iTunes. I installed 3ivx's version 4.5 codec (perhaps there is a better one that I should be using?). I started with a totally empty library, installed WMP TSE 1.4 and everything was fine. It was configured to refresh the tags up on addition to the library or if I hit the refresh button. I started adding songs, pointed it to my directory with several gigabytes of music and it froze. I let it sit for a couple hours: no luck.

      So then, (after doing CTRL-ALT-DELETE to exit WMP) I opened WMP with the WMP TSE plugin disabled. I pointed WMP to add music from that folder: no problem. I then enabled the plugin and hit the refresh button inside the plugin configuration settings and it froze again. I let it sit for a few hours: again no luck.

      I have tried to use older versions of WMP TSE and the same thing happened, I have also reinstalled several times and had the same issues. Interestingly enough though, I installed it on my laptop (running XP and WMP11) and added about 10 m4a files to the WMP library and everything worked perfectly. I then added a few gigabytes of M4A's and had the same issues as with Windows MCE 2005.

      So, maybe this gives you some ideas on what might be causing problems?

      I really think what you are doing is great and I wish you luck!

      Thanks for doing this,

    • Zoltan

      Zoltan - 2007-06-23

      HI Guys

      To elaborate: I start with a clean library (having deleted media files from Documents and Settings\All Users\Application Data\Microsoft\Media Index  nnn.wdb. I have tried both 'Add' under 'options' and under 'file'. I Never drag and drop as there is 450Gb of music which is a bit big. WMPTSE always enabled to start. WMP11 'sees' the files (m4A and mp3) but then after loading about 200 m4a wmp11 seems to freeze. Processor loading is 100% and only stopping app in CTRLALT DEL will restore the machine. After reboot WMPTSE is disabled. I've repeated this on several other machines all with XP SP2 latest wmp11, patches etc.
      WMPTSE 1.4 used in every case. I use Orban plug in to play m4a.
      ver1_0_33. Good Luck and if you need me to do some diagnostic for you I'm happy to help. Machines are mostly Compaq Evo D51S 2.4Ghz with
      1 Gb RAM.


    • Zoltan

      Zoltan - 2007-07-02

      If it helps, I tried the same thing on Win 2k machine running WMP10, adding same external (networked) library to wmp with Orban m4a plug-in and wmptse on. Crashed after about an hour. On restarting wmp plug in was disabled.
      Going to bed now in despair...... anything but Itunes FFsake..!

    • M@B

      M@B - 2007-07-03

      Hi, i STRONGLY advise you to use the 'Watch Folder' method. the 'add folder' or 'add file' will flood WMPTSE with file information which ultimatelly leads to crash (i know it is a bug, consequence of the hack inside WMP).

      Under WMP11, you will simply click no the 'Library' menu button (the arrow under Library). Then 'Add to Library'. There you will add the folder to watch inside the list...(network shares are available).

      WMP will then 'flow' smoothly the file list into WMPTSE and all should be good (it takes some time for large libraries but it should be ok).

      try this and let me know


    • Zoltan

      Zoltan - 2007-07-08

      Hi Mab

      Deleted the library as before. Pointed to local 500GB drive containing music. When you click add it of course starts importing the library immediately. I cancel this and leave wmp11 open monitoring as you suggested. Came back after hour and half and wmp11 is frozen. When restarted, wmp11 lock out plug in. If you re-enable and restart tag support it crashes immediately. I think wmp10 on my win 2k is more forgiving as there seems to be more m4a files in its library. This might be to do with the extra data (album covers or something)in wmp11. I think the hack might need some work. Any ideas?

      Cheers, Z

      • TEIF

        TEIF - 2007-07-08

        I have *exactly* the same issue as Zoltan, only I am trying to import FLAC files instead of m4a.

    • Zoltan

      Zoltan - 2007-07-24

      HI Guys

      I'm still looking here in hope! Any thoughts?

    • David Lyon

      David Lyon - 2007-07-25

      I found that when WMP is scanning a library of m4a files for adding, if it encounters even one bad/corrupt file, the process will jump to 100% CPU and freeze.

      Upon restarting, the plugin will be deactivated, and the library only as far as it got the last time.

      By ordering the entire library according to the date the files were added, you can check which file was added last, and which one was due to come next in order. Check those files to see if there's any problems playing them back. If they're bad, delete them, turn on the plugin, and it should proceed past that point.

    • Zoltan

      Zoltan - 2007-07-28

      HI Dave

      Nice idea. You mean the WMP library ? I think this will be very labour intensive; I have to check 3800 m4a albums for defects! I have tried some mp4 diagnostic tools that can run batch which haven't found any faulty rips. I'll try your trick and see if the library loads further by removing the sticking files (if indeed this is the mechanism by which it crashes). Anyone else had any luck?


    • David Lyon

      David Lyon - 2007-07-28

      You only need to check the files that cause the process to stall.

      If you have 400 files, and you get 44% through the process, once the player restarts, whatever the latest file was to be added, check it and also the next one to see if it plays properly. If not, delete that one file, and resume the add process, until it freezes again, whereby you repeat the process.


Log in to post a comment.

Get latest updates about Open Source Projects, Conferences and News.

Sign up for the SourceForge newsletter:

JavaScript is required for this form.

No, thanks