Unable to add OGG files to WMP 11 Library

  • warder

    warder - 2006-05-18


    I've installed the ogg directshow filters and can play ogg files in WMP 11 beta and have then installed the Tag Support Extender.

    I notice under the File Types list in the Options there is now an OGG option along with many other entries that are checked, however when I drag an OGG file or directory containing OGG files, the best I can do is play the files - they are never added to the Media Library with their tag info.

    Likewise, doing a scan for media files (F3) doesn't find or add any OGG files.

    What am I doing wrong?


    • M@B

      M@B - 2006-05-20

      I think you're not doing anything wrong

      I'm not able to install WMP11 under my Win2K box, (yeah, i know) and no documentation has been released by Microsoft.

      So i can't help anyone on this subject. I'm just as completelly blinded as you are.

      For the OGG in WMP11 Library, i remember that the first release of WMP10 was including the charming "MLS bug", which stands for MediaLibrary Support bug. It simply disabled the customizing in the Library. Maybe Microsoft is doing it all again. Can't say....It's beta though. So don't be too bad with MS wink.gif


    • warder

      warder - 2006-05-21

      I have downloaded the source and have a debug library... can debug calls into the DLL from WMP but am not immediately sure what it is supposed to do. 

      I do see several calls into
      CWMPTagSupportExtender::RefreshMetaDataForFile which to all intents appears to have correct tag information during the call.

      Any hints?

      • M@B

        M@B - 2006-05-22

        As you can see on the next thread, it seems that the problem reside in WMP MLS handling.
        You will not be able to force "MediaType" by hand, so you won't be able to correct the bug with that.

        On a "how it works" part, it's the normal behaviour of WMPTSE to call RefreshMetaDataForFile() ;) This function then calls different layers of "be sure to point the right metadata in the right place",then call the support DLL and then calls back the right WMP function (setMediaInfo most of the time).

    • warder

      warder - 2006-05-21

      ok, I've worked out what was wrong and have fixed it on my system.

      By dumping all the tags on the files in the media library I could see that files that worked had a "MediaType" of "audio", but for some reason my OGG files didn't.  They all had a MediaType of "other" which was preventing them from showing up.

      A useful feature (improvement) for the plug-in might be to iterate through the IWMPMediaCollection and check the file types on all files with extensions supported by the plug-in and permit the user to remove those from the library which will then allow them to be re-added.  I did try correcting the MediaType flag in RefreshMetaDataForFile but it always got set back.  Deleting my library and re-adding the files fixed the problem but was painful because I had to re-add everything, tweaking names/album associations etc.

      Anyways, the plug-in does work with WMP11, but only if everything is installed BEFORE adding them... otherwise they are flagged forever as non-music files :)

      • rokdd

        rokdd - 2006-10-28

        thanks for your tip. i searched long time for my mistake(or of a installed software). your ogg problem appears with m4a, too. tip if you don't want to delete all files: Library->other media->select all (shall be all the files with tags of failure files) and delete ONLY FROM LIBRARY.. and to add use the wmpfunction..


        • M@B

          M@B - 2006-10-30

          It's seems it's a Microsoft 'optimisation' feature. The first time you add a file in the library seems to fix the MediaLibrary filetypes forever.

          So, if you install WMPTSE after it...You'll end up with no choice but to supress all the library first and then add you "extended" files...

          No WMPTSE workaround will be possible as long as Microsoft maintain this 'optimisation' behaviour...

    • M@B

      M@B - 2006-05-22

      Hum, so it's a MLS bug.

      The "other" or "audio" type is handle by WMP Media Library Support...

      And WMP does force it if you (or any plug-in) try to WMPMedia->setMediaInfo it by hand. It is supposed to be a read-only MetaData.

      As long as MS as not activated Media Libary Support or debugged it, WMPTSE will not entirelly work...

    • alidaf

      alidaf - 2007-01-22

      I had this problem.  I deleted all my databases and forced a re-read, from which point it worked.


Log in to post a comment.

Get latest updates about Open Source Projects, Conferences and News.

Sign up for the SourceForge newsletter:

No, thanks