From the xsd's in the doc directory, WixEdit determines which namespaces are used, and adds the correct extensions to the -ext argument.

WixEdit also uses the xsd's to determine what elements can be created from the extension and where they can be used. For example from the Util namespace, the User element can be added as sub element of a Product element. Like this:

<Wix xmlns="http://schemas.microsoft.com/wix/2006/wi" xmlns:util="http://schemas.microsoft.com/wix/UtilExtension">
  <Product ...>
    <util:User ... />

For the UI extension, WixEdit checks for UIRef elements and does not require any xsd.

It seems you are using a <CustomAction BinaryKey="WixCA" ... /> which also requires an extension to be added to the commandline. WixEdit is not (yet) able to determine which extensions to add from CustomActions.

It would be nice indeed to have some documentation for WixEdit...


On Thu, May 27, 2010 at 11:53, Armin Linder <arminlinder@arminlinder.de> wrote:
Hi WixEdit users,

I am using, and came across the following problem:

I tried to author a msi which uses WixUIExtension and WixUtilExtension.

Light won't run through because of "Unresolved reference to symbol
'Binary:WixCA' in section 'Product:*'". After some research I found,
that I need to add a reference to the WixUtilExtension library using the
-ext command line switch for light.exe.

This is odd, because in the documentation on page


it says:

"The use of the WiX extensions is really easy and blends in with the
standard functionality. You only have to point WixEdit to the directory
containing the XML Schema Definitions (XSD) of the extensions, which are
located in the /doc sub directory of the WiX installation."

Some instructions about *how* to "pont WixEdit to the directory ..."
would really be helpful. After flipping through all the WixEdit dialogs
I finally found the "Locations" list in the "Tools" - "Options" dialog,
and the Xsds setting seemed promising, but alas, it alredy pointed to
the /doc subdirectory of the WiX toolkit which came with WixEdit
(3.0.5419.0), and changing it to point to the lates WiX build
(C:\Program Files\Windows Installer XML v3\doc) didn't change anything
either. Manually changing the Candle and Light command lines to "Custom"
using the "Build" - "Settings" dialog worked, however this does not at
all match what is written on the above page.

Looking closer into the problem revealed, that WixEdit did indeed add
the -ext WixUIExtension switch, but forgot the -ext WixUtilExtension
switch. I suspected that there was probably due to an Xsd file/entry
missing in the /doc directory, and indeed, there wasn't any file which
lokked like it matched, but searching all the xsd files for
"WixUIExtension" revealed no hits as well. So it seems that the contents
of the doc directory isn't directly related to those two Wix extensions.

Am I missing something, or is this a bug in WixEdit?




Wixedit-users mailing list