#3270 Created wix project using 1.0 is not building on Windows 8 with .NET 4.0

v4.0
closed
None
2014-08-26
2013-04-17
No

Hi,

This is regarding the wix project created in wix 1.0. I have a old wix project using 1.0 version to install my product. It was working fine with .NET 1.1 Windows XP to .NET 3.5 Windows 7, but it is not working on windows 8 with .NET 4.0. If we try to build the installer on Windows 8 then it ask to install the .NET 3.5. If we install .NET 3.5 on Windows 8 then everything is working fine (installer build properly with wix 1.1).
Can you please tell do we have any solution so that product.wxs created using wix 1.0 can build on Windows 8 with .NET 4.0.

Other solution could be we would have to migrate product.wxs using wix 3.6, that is working with .NET 4.0. But it requires .NET 2.0 with service pack 1. It will not work with .NET 1.1.

Can you please suggest the appropriate solution?

Regards
Navanit

Discussion

  • Rob Mensching

    Rob Mensching - 2013-04-17
    • status: open --> closed
    • assigned_to: Rob Mensching
     
  • Rob Mensching

    Rob Mensching - 2013-04-17

    WiX v1.0 is not supported and was never designed to work with NETFX 4.0. You'll need a later version of the WiX toolset but NETFX 1.1 isn't a supported platform either. However, if you want to contribute fixes to help the WiX v3.8 or later run on NETFX 1.1, we'd consider those.

     

Get latest updates about Open Source Projects, Conferences and News.

Sign up for the SourceForge newsletter:

JavaScript is required for this form.





No, thanks