#3195 Burn InstallCondition not followed for slipstream MSP

v3.8
migrated
nobody
None
2013-08-21
2013-01-23
No

The installer installs an MSI and a slipstream MSP patch. The InstallConditions for the two modules are different and I want the MSP installed only in specific cases. However, if the MSI is installed, the MSP seems to be installed even if the logs indicate the install condition is false.

Discussion

  • Bob Arnson

    Bob Arnson - 2013-01-24

    Please attach the Burn log from a failing case.

     
  • Roger Amorim

    Roger Amorim - 2013-01-24

    Excerpts from the log (The ESRI_10_SP5 package is the one that should not have been installed):

    [0C84:0D38][2013-01-22T13:57:44]i000: PlanPackageComplete [PackageID:ESRI_10_SP5] [Requested:Absent] [State:Absent] [Rollback:None] [Status:0]
    [0C84:0D38][2013-01-22T13:57:44]i201: Planned package: NetFx40Web, state: Present, default requested: Present, ba requested: Present, execute: None, rollback: None, cache: No, uncache: No, dependency: None
    [0C84:0D38][2013-01-22T13:57:44]i201: Planned package: VC2005, state: Absent, default requested: Present, ba requested: Present, execute: Install, rollback: None, cache: Yes, uncache: No, dependency: None
    [0C84:0D38][2013-01-22T13:57:44]i201: Planned package: VC2008, state: Present, default requested: Present, ba requested: Present, execute: None, rollback: None, cache: No, uncache: No, dependency: None
    [0C84:0D38][2013-01-22T13:57:44]i201: Planned package: VC2010, state: Absent, default requested: Present, ba requested: Present, execute: Install, rollback: None, cache: Yes, uncache: No, dependency: None
    [0C84:0D38][2013-01-22T13:57:44]i201: Planned package: Oasis, state: Absent, default requested: Present, ba requested: Present, execute: Install, rollback: Uninstall, cache: Yes, uncache: No, dependency: Register
    [0C84:0D38][2013-01-22T13:57:44]i201: Planned package: Resources, state: Absent, default requested: Present, ba requested: Present, execute: Install, rollback: Uninstall, cache: Yes, uncache: No, dependency: None
    [0C84:0D38][2013-01-22T13:57:44]i201: Planned package: ESRI_10, state: Absent, default requested: Present, ba requested: Present, execute: Install, rollback: None, cache: Yes, uncache: No, dependency: Register
    [0C84:0D38][2013-01-22T13:57:44]i201: Planned package: ESRI_10_SP5, state: Absent, default requested: Absent, ba requested: Absent, execute: Install, rollback: None, cache: Yes, uncache: No, dependency: Register

    At the end of the log I get:

    [0C84:0D38][2013-01-22T14:13:36]i000: ExecuteMsiMessage [PackageId:ESRI_10] [Message:Action 14:13:36: RemoveExistingProducts. Removing applications] [MessageType:ActionStart] [Result:None] [Data:System.Collections.ObjectModel.ReadOnlyCollection1[System.String]] [DisplayParameters:0] [0C84:0D38][2013-01-22T14:13:36]i000: ExecuteMsiMessage [PackageId:ESRI_10] [Message:Action 14:13:36: WiseCleanup. ] [MessageType:ActionStart] [Result:None] [Data:System.Collections.ObjectModel.ReadOnlyCollection1[System.String]] [DisplayParameters:0]
    [0C84:0D38][2013-01-22T14:13:37]i000: ExecuteMsiMessage [PackageId:ESRI_10] [Message:1: 2 2: 0 ] [MessageType:CommonData] [Result:None] [Data:System.Collections.ObjectModel.ReadOnlyCollection1[System.String]] [DisplayParameters:0] [0C84:0D38][2013-01-22T14:13:37]i000: ExecuteMsiMessage [PackageId:ESRI_10] [Message:1: 2 2: 1 ] [MessageType:CommonData] [Result:None] [Data:System.Collections.ObjectModel.ReadOnlyCollection1[System.String]] [DisplayParameters:0]
    [0C84:0D38][2013-01-22T14:13:37]i000: ExecutePackageComplete [PackageId:ESRI_10] [Restart:RestartRequired] [Result:None] [Status:0]
    [0C84:0D38][2013-01-22T14:13:37]i319: Applied execute package: ESRI_10, result: 0x0, restart: Required
    [065C:07C0][2013-01-22T14:13:37]i325: Registering dependency: {6983c33a-74b8-4ada-866d-f2e86b82078c} on package provider: {4384DA75-4135-4B0F-8B56-37BB281CAAE8}, package: ESRI_10
    [065C:07C0][2013-01-22T14:13:37]i323: Registering package dependency provider: {BAD6F213-7B94-4DDA-9A2D-5016460409E8}, version: (null), package: ESRI_10_SP5
    [065C:07C0][2013-01-22T14:13:37]i325: Registering dependency: {6983c33a-74b8-4ada-866d-f2e86b82078c} on package provider: {BAD6F213-7B94-4DDA-9A2D-5016460409E8}, package: ESRI_10_SP5
    [0C84:0D38][2013-01-22T14:13:37]i000: ExecuteComplete [Status:0]
    [0C84:0D38][2013-01-22T14:13:37]i000: ApplyComplete [Result:None] [Restart:RestartRequired] [Status:0]
    [0C84:0D38][2013-01-22T14:13:37]i399: Apply complete, result: 0x0, restart: Required, ba requested restart: No

    Note that it does not log the ESRI_10_SP5 package as installed but it is installed on the system.

     
  • Rob Mensching

    Rob Mensching - 2013-03-04
    • Milestone: v3.7 --> v3.8
     
  • Rob Mensching

    Rob Mensching - 2013-08-21
    • Status: open --> migrated
     

Get latest updates about Open Source Projects, Conferences and News.

Sign up for the SourceForge newsletter:





No, thanks