#10 Dialog not hiding after submitting

v1.0 (example)
closed
singhj
UI (2)
5
2014-07-16
2014-02-10
SHADEVEN
No

The dialog (modal or non-modal) does not hide after clicking the Submit button.
Reproduce steps:
1. Go to Product list and click Quick Create button.
2. The Dialog pops up and enter Product details, and click Save button.
3. The dialog does not disappear, however the new Product is created successfully.
4. If the user does not enter the mandatory field and click Save button, the dialog does not disappear as well. The error message appears though.

Related

Bugs: #10

Discussion

  • SHADEVEN

    SHADEVEN - 2014-02-10
    1. The issue is mainly caused by sharing the h:form with others. Previously modalDlgProductComponent.xhtml shares the form with other component. It should have its own form during submit. After assigning a from specific to modalDlgProductComponent.xhtml, the dialog behaviors as normal.

    2. The code base of primeseam is missing a javascript "common.js" which includes an important function named "handleDialogSubmit". This is the function invoked by every modal dialog component during the oncomplete callback.

     
    Last edit: SHADEVEN 2014-02-10
  • SHADEVEN

    SHADEVEN - 2014-02-10
    • status: open --> closed
     
  • singhj

    singhj - 2014-06-08
    • Description has changed:

    Diff:

    --- old
    +++ new
    @@ -4,3 +4,4 @@
     2. The Dialog pops up and enter Product details, and click Save button.
     3. The dialog does not disappear, however the new Product is created successfully.
     4. If the user does not enter the mandatory field and click Save button, the dialog does not disappear as well. The error message appears though.
    +
    
    • status: closed --> open
     
  • singhj

    singhj - 2014-06-08

    Issue has reappeared with PF 5 migration

     
  • SHADEVEN

    SHADEVEN - 2014-06-09

    The issue is now fixed. In PrimeFaces 5, Widgets must be referenced via "PF". Code checked in. Please test and provide feedback.

     
    Last edit: SHADEVEN 2014-06-09
    • SHADEVEN

      SHADEVEN - 2014-06-09

      Jag,

      I have fixed the issue. Please see my comments for details.
      Code checked in. Please test and provide feedback.

      Regards,

      Steven Wu

      On Mon, Jun 9, 2014 at 8:57 PM, SHADEVEN shadeven@users.sf.net wrote:

      The issue is now fixed. In PrimeFaces 5, Widgets must be referenced via
      "PF".


      Status: open
      Group: v1.0 (example)
      Labels: UI
      Created: Mon Feb 10, 2014 08:10 AM UTC by SHADEVEN
      Last Updated: Sun Jun 08, 2014 10:09 PM UTC
      Owner: SHADEVEN

      The dialog (modal or non-modal) does not hide after clicking the Submit
      button.
      Reproduce steps:
      1. Go to Product list and click Quick Create button.
      2. The Dialog pops up and enter Product details, and click Save button.
      3. The dialog does not disappear, however the new Product is created
      successfully.
      4. If the user does not enter the mandatory field and click Save button,
      the dialog does not disappear as well. The error message appears though.


      Sent from sourceforge.net because you indicated interest in
      https://sourceforge.net/p/witchcraft/bugs/10/

      To unsubscribe from further messages, please visit
      https://sourceforge.net/auth/subscriptions/

       

      Related

      Bugs: #10

      Attachments
  • SHADEVEN

    SHADEVEN - 2014-07-16
    • assigned_to: SHADEVEN --> singhj
     
  • SHADEVEN

    SHADEVEN - 2014-07-16

    Jag,

    Assigning the issue back to you.

     
  • singhj

    singhj - 2014-07-16
    • status: open --> closed
     

Get latest updates about Open Source Projects, Conferences and News.

Sign up for the SourceForge newsletter:





No, thanks