Dumb question

Help
Anonymous
2000-02-27
2000-11-09
  • Anonymous - 2000-02-27

    I've been using wipe since release 0.56 on my Linux box. Since I've been working on BSD a lot lately, I am asking you: was wipe-1.2.x tested on any other platform other than GNU/Linux? Maybe I should try compile and debug but you know, sometimes you feel better trying to avoid headaches in advance. Thanks. 8)

     
    • Tom Vier

      Tom Vier - 2000-02-29

      unfortunely, i only have one box (not counting my brother's se/30), an old first generation pmac; it only runs mklinux and mac os, so i don't have any means to test it on BSD (cept maybe for those compaq test drive boxes...hmm...).

      i just uploaded 1.2.2 and it successfully wipes partitions on my mklinux box. unless my disklabel code or includes are screwed up, it should work fine on BSD boxes.

       
      • Greg Broiles

        Greg Broiles - 2000-10-26

        I tried to build it on FreeBSD 4.1; configure seemed to run OK, but this is what I get when I try to make-

        jasper$ make
        gcc -pipe -O3  -finline-functions -ffast-math -fomit-frame-pointer  -funsigned-char -I. -DFREEBSD4  -o wipe.o -c wipe.c
        wipe.c:944: syntax error
        wipe.c: In function `checkfile':
        wipe.c:1752: `S_IFMT' undeclared (first use in this function)
        wipe.c:1752: (Each undeclared identifier is reported only once
        wipe.c:1752: for each function it appears in.)
        wipe.c:1754: `S_IFCHR' undeclared (first use in this function)
        wipe.c:1755: `S_IFLNK' undeclared (first use in this function)
        wipe.c:1756: `S_IFIFO' undeclared (first use in this function)
        wipe.c:1757: `S_IFSOCK' undeclared (first use in this function)
        wipe.c:1758: warning: unreachable code at beginning of switch statement
        *** Error code 1

        Stop in /home/gbroiles/wipe-1.2.2.
        jasper$

         
        • Tom Vier

          Tom Vier - 2000-11-04

          someone gave me a patch for freebsd that i'll intergrate into the next release (which i'm working on now). in the mean time, i'll upload it to sourceforge. look on the project patches page.

           
          • Greg Broiles

            Greg Broiles - 2000-11-09

            Tried the patch; it worked fine. Thanks.

             

Log in to post a comment.