1053 Startup error with service sample

Help
2012-05-09
2013-09-27
  • abest.tandemradiology

    I was attempting to port my java app to winrun4j, and was having issues, so I attempted to just use the sample code included with the distro, and even that didn't work for me. I'm wondering what I'm missing.

    I'm using the 0.4.4 distro. Sun Java 1.6.0_30

    I followed the instructions from the main page:

    Create a test directory C:/test.
    Copy WinRun4Jc.exe to C:/test and rename to service.exe.
    Copy service.ini to C:/test.
    Copy WinRun4JTest.jar to C:/test.
    Run service.exe -WinRun4J:RegisterService.

    This all works fine. When I attempt to start the service, I get an error dialog, and two messages in the event log.

    The WinRun4J Test Service service failed to start due to the following error: The service did not respond to the start or control request in a timely fashion.

    A timeout was reached (30000 milliseconds) while waiting for the WinRun4J Test Service service to connect.

    Does anyone have suggestions as to what I'm missing?

    Thanks in advance.

     
  • abest.tandemradiology

    I believe I have this figured out. It has something to do with the VM paths. Thank you if you've read this.

     
  • Doug

    Doug - 2012-05-31

    I have had a similar problem.  How did you resolve your problem?

    Thanks,
    Doug

     
  • Nobody/Anonymous

    I'm having this problem too. Anyone have a solution?

     
  • abest.tandemradiology

    I think it's a bit of a catch-all error. The way I went about debugging it was to run the program with the standalone exe wrapper. If it starts up without errors, then maybe look at the return code of the server. Generally if I got this error, the standalone one didn't work either.

    There's probably a better way to do it, but that's what I did to track it down. For me it was something about the location of the JVM that it didn't like.

     
  • Jean Almonord

    Jean Almonord - 2013-09-27

    I had this same error. When I took a look at the log I realized that I was missing the WinRun4J jar in my classpath. Adding it to my classpath solved the issue.

     

Log in to post a comment.

Get latest updates about Open Source Projects, Conferences and News.

Sign up for the SourceForge newsletter:

JavaScript is required for this form.





No, thanks