#1 WinNT, Win2K crash

Windows NT, 2000
closed-fixed
7
2002-06-13
2001-03-17
Jim Paris
No

Crashes for some people under WinNT and Win2K,
particularly after a "learn" or "analyze".
Almost certainly thread or window related.

Discussion

  • Jim Paris

    Jim Paris - 2001-03-20

    Logged In: YES
    user_id=175928

    Three files attached: an e-mail describing the bug
    and two debug files (only the first is really relevant)

     
  • Jim Paris

    Jim Paris - 2001-03-20

    Description of problem

     
  • Jim Paris

    Jim Paris - 2001-03-20

    Debug file .. WinLIRC crashes at (or shortly after) the end of this

     
  • Jim Paris

    Jim Paris - 2001-03-20

    A second debug file, showing that the socket was never freed

     
  • Jim Paris

    Jim Paris - 2001-03-20
    • assigned_to: nobody --> baily
     
  • Nobody/Anonymous

    Logged In: NO

    After almost every learn phase.... :-(

     
  • Jörgen Birkler

    Jörgen Birkler - 2002-03-06

    Logged In: YES
    user_id=476111

    The problem is related to the fact that the workings
    threads like learn, irdriver, deamon, etc are accessing the
    handles and objects in the main winproc thread.
    To totally avoid the problem no such accesses are allowed.
    One or two problem also had to do with a handle not being
    set to NULL after it was destroyed. Hopefully I can check
    in files that fix some of the problems.

     
  • Jim Paris

    Jim Paris - 2002-03-27
    • status: open --> closed
     
  • Jim Paris

    Jim Paris - 2002-03-27

    Logged In: YES
    user_id=175928

    Apparently fixed in winlirc-0.6pre3. Please let us know
    if you still see this problem!

     
  • Scott Baily

    Scott Baily - 2002-06-13
    • status: closed --> closed-fixed
     

Log in to post a comment.