Portable?

2004-07-02
2004-07-06
  • Per Nilsson

    Per Nilsson - 2004-07-02

    As stated in the cuj article (July 2004):
    "The library is portable".

    But doesnt support (the quite widely used) VC++ 6.

    I bet there are perfectly valid reasons for this limitation. I also guess the win32gui is really super - at least it seems to be - I can't tell really, it's not portable enough for me to try it out...

     
    • John Torjo

      John Torjo - 2004-07-06

      I'm sorry about VC6.

      Trust me, I've used it too much, to know its limitations.

      And one of them (handling of templated member functions) sucks just too much. In order to allow for VC6 I would have to make too many workarounds, and I really don't want that.

      I highly recommend you upgrade to VC71 - if only for template support.

      (note that win32gui makes **heavy** use of templates)

      Best,
      John

       

Log in to post a comment.

Get latest updates about Open Source Projects, Conferences and News.

Sign up for the SourceForge newsletter:

JavaScript is required for this form.





No, thanks