Permission denied error with windows 8 wim files

JackF
2014-01-13
2014-01-14
  • JackF

    JackF - 2014-01-13

    Hallo,
    I'm using wimlib version 1.6.0 on Windows 7 to apply system images to NTFS drives.
    Using Windows 7 wim images works nice, just one warning.

    [WARNING] Re-assigning inode numbers due to inode inconsistencies

    But with Windows 8.0 and 8.1 wim images there are many error happening.
    Like the this one.

    [ERROR] Can't open \?\X:\Windows\WindowsShell.Manifest: Permission denied

    [WARNING] - Could not set security descriptor at all
    on 49 files or directories.
    [WARNING] To fully restore all security descriptors, run the program
    with Administrator rights.

    I don't think that it's a permission issue here,
    cause I always run command prompt with admin rights.

     
    Last edit: JackF 2014-01-13
  • synchronicity

    synchronicity - 2014-01-13

    Hi,

    I believe I've fixed the problem with setting security descriptors. It was caused by a bug in the Windows API which I've added a workaround for.

    The other warning you noticed (regarding inode numbers) is caused by the WIM image having invalid hardlink metadata. This is a known issue in released Windows 7 install.wim's. wimlib has to apply a heuristic algorithm to recover the correct metadata. This is expected to work correctly, but I've adjusted the warning message a bit.

    You can try the latest 1.6.1-BETA version from the https://sourceforge.net/projects/wimlib/files/testing/ directory.

     
  • JackF

    JackF - 2014-01-14

    The new warning on windows 7 wim files sounds much better.

    I tried the beta with all my Windows 8.x wim files and
    it works perfect now!

    Thanks a lot Eric

     

Log in to post a comment.