Whonix 0.5.6 32 bit users do not have to update to Tor Browser 2.3.25-9

When you run whonixcheck or Whonix's internal torbrowser updater, if you use Whonix 0.5.6 32 bit users (almost everyone, all who downloaded Whonix, not people who made their own 64 bit builds), you will see:

Currently installed version: 2.3.25-8
Online detected version : 2.3.25-9

And when you try to update.

-
Tor Browser Update Check:

ERROR: GPG download signature could NOT be verified.
ERROR: Tor Browser update failed! Try again later.

Please ignore version 2.3.25-9. Its not for you. Only the 64 bit version of Tor Browser was updated. [1]

It looks like an upstream bug and I already asked The Tor Project [2] [5]. (No reaction at time of writing.)

Just stay with 2.3.25-8, which is still the recommend version for 32 bit TBB users. When a new version higher than 2.3.25-9 gets released, try to update again.

If you don't have version 2.3.25-8 already, please manually update Tor Browser. [4]

If there are questions about this very topic, please ask in its dedicated forum thread [3].

[1] https://blog.torproject.org/blog/updated-64-bit-linux-tor-browser-bundles-crash-fix
[2] https://lists.torproject.org/pipermail/tor-talk/2013-June/028438.html
[3] https://sourceforge.net/p/whonix/discussion/general/thread/0d73854e/
[4] https://sourceforge.net/p/whonix/wiki/ManualTBupdate/
[5] https://trac.torproject.org/projects/tor/ticket/9152

Posted by Anonymous 2013-06-15

Log in to post a comment.