whichbot v1.05

2007-01-15
2013-04-25
  • Mike Cooper

    Mike Cooper - 2007-01-15

    Turned out there was a build issue in v1.04 for the Windows version which was almost certainly causing the "gorges don't build" issue people were seeing.  The Linux version should have been fine.

    I put up v1.05 which should be exactly the same except that the Windows version should actually work this time.

     
    • Drek

      Drek - 2007-01-15

      Which explains why nobody from my clan reported this problem.  Thanks clam.

       
    • jeff

      jeff - 2007-01-16

      Has anyone else tried wb 1.05 on ns 3.1.3 win32?

      I have noticed the gorges building RT's but not hives.  Was playing ns_tanith and the starting hive was waste.  2 gorges went and built 5 res and just ran around fusion hive for well over 30 minutes and built nothing but the res there.  I didn't even see any chambers either.

       
    • jeff

      jeff - 2007-01-16

      After extended play on ns 3.1.3 dedicated server, win32, wb 1.05 gorges are only building res and nothing else.  I was using a fresh install.  Just to test something out, I dropped wb 1.03 dll over the 1.05 install and restarted the server.  Low and behold, wb is building up a storm.  What am I doing wrong with wb 1.05?

       
    • Rich Strom

      Rich Strom - 2007-01-16

      Are you using the correct 'whichbot.txt'? The current 'whichbot.txt' is not compatible with version 1.03 or older.

      If you overwrote 1.05 with 1.03 without changing the config (or vice-cersa) you should get warnings in the server console similar to this -> Warning: chamber order config incorrect.  Gorge bots will not function correctly.

      (note:you actually have be able to see the server console to view that message.)

       
      • Drek

        Drek - 2007-01-16

        Any chance that the wrong whichbot.txt got included with 1.05?

         
        • jeff

          jeff - 2007-01-16

          I see what it was.  I was using the whichbot.txt that come with wb 1.04.  Funny part is, it looks completely identical to 1.05's config.  What got changed?

           
          • Rich Strom

            Rich Strom - 2007-01-17

            The whichbot.txt in 1.05 and 1.04 are compatible, the only difference being the inclusion of the missing 'allow_combat_onos' variable in the admin section of 1.05.

            The differences between 1.04 and earlier versions is both subtle and obvious. The obvious being the addition of [../combat_upgrade_path] section. The subtle and easily missed change was the addition of '.' in the /strategy/builder section declaration(ie. [../builder] instead of [./builder]). If you tried upgrading your old text by copying over the changes from the new text, you probably would miss that.

             
    • jeff

      jeff - 2007-01-17

      After reveiwing what you just stated against what my configs contained.  I did catch on to obvious but missed the subtle.  It was the [../builder] vs [./builder] code that I did in fact overlook.  Thanks for pointing that out masked_carrot.  The bots are working good now.

      One thing I have noticed is that it was great to see onos in combat.  Also the skulks are using xeno and fades are using acid rocket from time to time.  Now the marines are running scared because the bots are using all the alien tools at thier disposal.  Great job!

       
    • Eric Watkins

      Eric Watkins - 2007-01-18

      I have to agree, the xeno surprised me the first time I had it happen, even tho I'd see mention of it in the change log. I was in the habit of not seeing xeno or onos. The new fade movement is super deadly and if a lerk gets on your head, it's all over.

      Nice work!

      Keep those nice updates coming!

       
    • Eric Watkins

      Eric Watkins - 2007-05-30

      I just nuked my wb install, downloaded 1.05 and re-installed.

      the 'meta list' command still reflects 1.02..

      Just FYI

       
    • Zim

      Zim - 2007-06-02

      i just did a 'meta list' to check my servers and both show up with v1.05

       
    • Eric Watkins

      Eric Watkins - 2007-06-03

      I'm guessing that's the windows build?

      Perhaps the linux build is lagged slightly or the version info isn't up to date.

       
    • Zim

      Zim - 2007-06-04

      yes.  sorry, i should have mentioned that.

       

Log in to post a comment.

Get latest updates about Open Source Projects, Conferences and News.

Sign up for the SourceForge newsletter:

JavaScript is required for this form.





No, thanks