Webware looks promising but I'm having trouble. (RH linux 6.2)
1.  I think I found an error in your documentation \Webware\WebKit\Docs\InstallGuide.html.  Where it says
  • Using a text editor, change the line in WebKit.cgi that reads WebKitDir = None to point to WebKit. For example, WebKitDir = '/home/me/Webware/WebKit'.
There is no such line.  There is a line that says WebwareDir = None
So I changed that line to WebwareDir = /home/jon/Webware

2.  Now, I don't know if its related or not but when I run bash AppServer I get
...If AppServer is called with no arguments, it will start the AppServer and record the pid of the process in appserverpid.txt
Error starting the AppServer
Invalid configuration file, /home/jon/Webware/WebKit/Configs/AppServer.config.
  File "WebKit/AsyncThreadedAppServer.py", line 378, in run
    server = AsyncThreadedAppServer()
  File "WebKit/AsyncThreadedAppServer.py", line 42, in __init__
  File "WebKit/AppServer.py", line 47, in __init__
    self._verbose = self.setting('Verbose')
  File "WebKit/ConfigurableForServerSidePath.py", line 15, in setting
    value = Configurable.setting(self, name, default)
  File "MiscUtils/Configurable.py", line 62, in setting
    return self.config()[name]
  File "MiscUtils/Configurable.py", line 56, in config
  File "MiscUtils/Configurable.py", line 92, in userConfig
    raise ConfigurationError, 'Invalid configuration file, %s.' % self.configFilename()
[root@rh62 WebKit]#

As you can see below, I do have that config file, and this is what it says
[root@rh62 Configs]# pwd
[root@rh62 Configs]# cat AppServer.config
        'PrintConfigAtStartUp': 1,
        'Verbose':              1,
        'Host':                 '',
        'Port':                 8086,
        'PlugIns':              [],
        'PlugInDirs':           ['..'],
        'ServerThreads':        10,
[root@rh62 Configs]# ls-l
total 24
-rwxr--r--    1 nobody   nobody        229 Feb 25 21:45 AppServer.config
-rwxr--r--    1 nobody   nobody       2270 Feb 26 10:58 Application.config
-rwxr--r--    1 nobody   nobody         68 Dec  7  2000 CGIAdapter.config
-rwxr--r--    1 nobody   nobody         68 Dec  7  2000 FCGIAdapter.config
-rwxr--r--    1 nobody   nobody         68 Dec  7  2000 ModPythonAdapter.config
-rwxr--r--    1 nobody   nobody        128 Jan 17  2001 OneShotAdapter.config

Any suggestions?  My first guess is that, because I copied these files from DOS the line-endings might be confusing things.  But I'm sufficiently confused that I'm going to wait for some guidance.  Thank you!
Here's what I got when I ran install.py
root@rh62 Webware]# python install.py
Webware for Python 0.5
        Date: Sun Jul 29 17:41:39 2001
  Python ver: 1.5.2 (#1, Feb  1 2000, 16:32:16)  [GCC egcs-2.91.66 19990314/Linux (egcs-
      Op Sys: posix
    Platform: linux-i386
     Cur dir: /home/jon/Webware
Scanning for components...
  yes WebUtils     yes WebKit
  yes UserKit      yes TaskKit
  yes PSP          yes MiscUtils
  yes MiddleKit     no DocSupport
   no Docs         yes COMKit
  yes CGIWrapper    no bin
Propagating stylesheets...
Processing raw doc files...
Could not evaluate dictionary starting at line 182.
Jonathan Schull