Can't subscribe to public calendar after changing web host

2013-10-23
2014-05-29
  • scopemonkey

    scopemonkey - 2013-10-23

    I have been using v1.2.7 on my old web host without problems and was able to subscribe to the a public calendar via xxxxx/webcalendar/publish.php?user=public. Worked great. Unfortunately, I had to change my hosting company (now with 1and1.com). No problem, I thought. I backed up the database as a .sql file. I created a new database with the new host, and imported the .sql file without problem. Installed webcalendar on the new host and fed the install all the required database info and all went well. All my data and settings were there. It works great with a browser interface. However, now when I go to subscribe to the public calendar with Calendar on my Mac, or with Thunderbird/lightning on a PC I get an error that "the data downloaded isn't valid". I tried a complete clean install--created a new database but did not import my old backup and put a new webcalendar install on the host and let it create all the tables, etc. I then logged in, created the public calendar, set publish to yes, and created entries all without problems yet I get the same error when trying to subscribe with a calendar program. Could this be something with the host and not webcalendar itself? PHP version is 5.4, mySQL5. Any thoughts and help appreciated.

     
  • cking_sf

    cking_sf - 2013-10-24

    Try

    /webcalendar/publish.php/public.ics

    (Some time ago, the URL was __public__.ics but I think the two underscore characters on either side have now been removed.)

     
    Last edit: cking_sf 2013-10-24
    • scopemonkey

      scopemonkey - 2013-10-26

      Unfortunately, that didn't work. I get the same error.

       
  • cking_sf

    cking_sf - 2013-10-28

    Can you download the .ics file directly from a browser? If so, how does it compare to another .ics like http://webcalendar.sourceforge.net/demo/publish.php/demo.ics ?

    Do you have "allow remote subscriptions" and "allow remote calendars" (System Settings | Other) set to yes?

     
  • scopemonkey

    scopemonkey - 2013-10-29

    No, it doesn't directly download with a browser. The browser displays a page stating: Error No user specified. I do have "allow remote subscriptions/calendars" set to yes for each.

     
  • cking_sf

    cking_sf - 2013-10-29

    Since this is the public calendar, do you have non-user calendars enabled (Settings | NonUser Calendars)?

    You might also want to check all your permissions on the files and directories, since the .ics doesn't seem to be getting created. A prior poster with 1&1 hosting seemed to have an issue, but that appears to be further in the process (asking for authentication to access the .ics file). http://sourceforge.net/p/webcalendar/discussion/11588/thread/43e0174a#0362

    Beyond that, I have no further ideas. Sorry.

     
  • Troy Judd

    Troy Judd - 2014-02-07

    Did you ever solve this...I'm having exactly the same issue but with a new installation

     
  • cking_sf

    cking_sf - 2014-05-29

    Having just upgraded, I now see a problem. The /includes/xcal.php file in the most recent package is v1.79.2.19 (2008/09/27). But upgrading to the newest one in the repository (1.108) didn't fix the problem either.

    Since my old one (1.91) worked with one hack, I just copied that to the current directory and suddenly, my ics feeds came back.

    The hack is for the public entries to show up. It's added to the export_ical function, just after line 894 in version 1.91. I have no idea where this code came from -- it must have been this forum, but I can't seem to track it down.

      $isall = (strcmp($id,'all') == 0);
      if ($isall)
        $user = "__public__";
    

    Of course, should you try this, be aware that the 1.91 file is also very old and may be vulnerable. It doesn't seem to work when adding this to the 1.108 file.

     

Log in to post a comment.

Get latest updates about Open Source Projects, Conferences and News.

Sign up for the SourceForge newsletter:





No, thanks